Bug 850465 - KDE Spin should be shipped with KDM as the default login manager
KDE Spin should be shipped with KDM as the default login manager
Status: CLOSED DUPLICATE of bug 850775
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker-kde
  Show dependency treegraph
 
Reported: 2012-08-21 11:45 EDT by Martin Bříza
Modified: 2012-08-23 16:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 13:06:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bříza 2012-08-21 11:45:27 EDT
According to https://fedoraproject.org/wiki/Features/DisplayManagerRework we should replace the line:
    enable gdm.service
that is already present in /usr/lib/systemd/system-preset/99-default.preset with:
    enable kdm.service
to make kdm the default login manager.
Comment 1 Rex Dieter 2012-08-21 11:47:03 EDT
in kde-sig meeting, we hadn't decided where best to put  this yet (in spin or in a pkg like kde-settings somewhere)
Comment 2 Kevin Kofler 2012-08-21 16:40:27 EDT
So, as per https://fedoraproject.org/wiki/Features/PackagePresets systemd DOES accept presets in /etc. I think the spin kickstart should dump the preset to /etc. It won't be owned by a package, so it should be treated as initial site policy to be edited directly by the admin, not written to a read-only file system.

Putting it in a package would make sense if it HAD to be in /usr, but packages changing distro defaults is not such a nice idea. I think it's better for the KDE spin kickstart to dump a file in /etc, as it did in the past with /etc/sysconfig/desktop.
Comment 3 Rex Dieter 2012-08-21 16:49:27 EDT
Halfline pointed out too that the old default ordering still takes place, so if only kdm is installed, it will get used.

I'm tempted to just rely on that, and be done with it.
Comment 4 Adam Williamson 2012-08-22 13:06:54 EDT
that would not cover DVD installs.

From the blocker meeting today it seems no-one is really entirely sure how systemd guys are expecting this to work, so I'm gonna close this as a dupe of 850775 - which is a more general statement of the problem - and change the component of that bug to systemd, so lennart can tell us how he actually expects this stuff to work.

*** This bug has been marked as a duplicate of bug 850775 ***
Comment 5 Kevin Kofler 2012-08-23 16:50:54 EDT
> that would not cover DVD installs.

DVD installs were not covered in the past either, they'd just rely on the then prefdm and now systemd defaults.

What we wrote /etc/sysconfig/desktop for was installations from the KDE spin which then got GDM added later, e.g. as a dependency (In particular, gnome-shell drags in GDM now.), so it didn't suddenly become the default.

Note You need to log in before you can comment on or make changes to this bug.