Bug 850497 - rhpkg/publican package fail on non-empty DocBook 5 subtitle
rhpkg/publican package fail on non-empty DocBook 5 subtitle
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 12:46 EDT by Douglas Silas
Modified: 2012-10-30 23:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:10:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached book that fails on the above commands (152.10 KB, application/x-xz)
2012-08-21 12:46 EDT, Douglas Silas
no flags Details
DB5 book that builds successfully but fails on described commands (155.99 KB, application/x-xz)
2012-08-22 04:32 EDT, Douglas Silas
no flags Details
Patch that fixes subtitle extractor when using DB5 (1.46 KB, patch)
2012-10-24 02:22 EDT, Douglas Silas
no flags Details | Diff

  None (edit)
Description Douglas Silas 2012-08-21 12:46:01 EDT
Created attachment 605984 [details]
Attached book that fails on the above commands

Description of problem: rhpkg or publican package fail on a DocBook 5 book that builds correctly.


Version-Release number of selected component (if applicable): 

[root@exige yum.repos.d]# yum info publican
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
Name        : publican
Arch        : noarch
Version     : 3.0
Release     : 0.fc17.t216
Size        : 38 M
Repo        : installed
From repo   : publican3
Summary     : Common files and scripts for publishing with DocBook XML
URL         : https://publican.fedorahosted.org
License     : (GPLv2+ or Artistic) and CC0
Description : Publican is a DocBook publication system, not just a DocBook processing tool.
            : As well as ensuring your DocBook XML is valid, publican works to ensure
            : your XML is up to publishable standard.

[root@exige yum.repos.d]# yum info rhpkg
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
Name        : rhpkg
Arch        : noarch
Version     : 1.14
Release     : 1.fc17
Size        : 124 k
Repo        : installed
From repo   : rhpkg
Summary     : Utility for interacting with rpm+git packaging systems
URL         : http://git.engineering.redhat.com/?p=users/jkeating/rhpkg.git
License     : GPLv2+
Description : A Red Hat plugin for the rpkg rpm+git packaging utility


How reproducible: use the attached book to try to package it.


Steps to Reproduce:
1. unlzop attached book
2. run:

rhpkg publican-build --lang en-US --message "Commit message"

or:

publican package --lang=en-US

3. weep and open Builder.pm and try to figure out why it failed.
  
Actual results:

[blah blah blah]
        Processing file tmp/en-US/xml_tmp/Chapter.xml -> tmp/en-US/xml/Chapter.xml
        Processing file tmp/en-US/xml_tmp/Describing_Errata_Release_and_Technical_Notes_for_Engineers.xml -> tmp/en-US/xml/Describing_Errata_Release_and_Technical_Notes_for_Engineers.xml
        Processing file tmp/en-US/xml_tmp/Preface.xml -> tmp/en-US/xml/Preface.xml
        Processing file tmp/en-US/xml_tmp/Revision_History.xml -> tmp/en-US/xml/Revision_History.xml
WARNING: You can not create RPM packages with a blank subtitle. Skipping RPM creation.
Could not execute publican_build: Publican failed to produce an SRPM


Expected results: Success


Additional info: none
Comment 1 Douglas Silas 2012-08-22 04:32:46 EDT
Created attachment 606172 [details]
DB5 book that builds successfully but fails on described commands

Re-attaching a book that builds. In playing around with it yesterday, I inserted an abstract under <info> in Book_Info.xml that caused it to fail to build. This one does work. This change does not affect this bug: rhpkg and publican package still fail in the same way, with:

WARNING: You can not create RPM packages with a blank subtitle. Skipping RPM creation.
Could not execute publican_build: Publican failed to produce an SRPM

This is bogus because <subtitle> in Book_Info is not empty--it is "<subtitle>sntahesntuhathue</subtitle>".
Comment 2 Jeff Fearn 2012-08-23 21:36:54 EDT
DocBook5 is a tech preview, none of the packaging code has been updated to support it. It's an extremely low priority at this time.
Comment 6 Douglas Silas 2012-10-24 02:22:59 EDT
Created attachment 632553 [details]
Patch that fixes subtitle extractor when using DB5

Proposed patch that fixes subtitle extractor by adding DB5 namespace and XSL template based on new xpath subtitle location in DB5.

Note You need to log in before you can comment on or make changes to this bug.