Bug 850524 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the file /SYSVbabeface (deleted).
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2a95ff5e98ed435f892483568a8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 14:25 EDT by Mikhail
Modified: 2012-09-21 19:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 19:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-08-21 14:25:11 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.2-1.fc17.i686
time:           Ср. 22 авг. 2012 00:24:59

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'write' accesses on the file /SYSVbabeface (deleted).
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/SYSVbabeface (deleted) default label should be etc_runtime_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /SYSVbabeface (deleted)
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed write access on the SYSVbabeface (deleted) file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep asfdemux0:sink /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:tmpfs_t:s0
:Target Objects                /SYSVbabeface (deleted) [ file ]
:Source                        asfdemux0:sink
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.4.3-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-1.fc17.i686 #1 SMP Wed Aug
:                              15 16:52:27 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-08-22 00:24:35 YEKT
:Last Seen                     2012-08-22 00:24:35 YEKT
:Local ID                      8714a613-fd8f-4ca7-9566-00999b663cc2
:
:Raw Audit Messages
:type=AVC msg=audit(1345573475.70:87): avc:  denied  { write } for  pid=3704 comm="asfdemux0:sink" path=2F535953566261626566616365202864656C6574656429 dev="tmpfs" ino=19365891 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmpfs_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1345573475.70:87): arch=i386 syscall=ipc success=no exit=EACCES a0=15 a1=1278003 a2=0 a3=b67fe848 items=0 ppid=1231 pid=3704 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=asfdemux0:sink exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: asfdemux0:sink,thumb_t,tmpfs_t,file,write
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t tmpfs_t:file write;
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t tmpfs_t:file write;
:
Comment 2 Miroslav Grepl 2012-08-22 07:12:58 EDT
Ok, it looks like we will need to add additional fixes.
Comment 3 Miroslav Grepl 2012-08-22 07:26:00 EDT
Fixed in selinux-policy-3.10.0-147.fc17.noarch
Comment 5 renke 2012-09-15 11:22:25 EDT
indeed, selinux-policy-3.10.0-147 does solve the thumbnailer problems, thanks a lot.

can we expect pushing of 147 to the repos anytime soon? according to Koji (http://koji.fedoraproject.org/koji/buildinfo?buildID=350108) it's still an update candidate.
Comment 6 Miroslav Grepl 2012-09-17 04:33:13 EDT
I am just working on a new build which is going to be submitted as an update today. Thank you for your testing.
Comment 7 Fedora Update System 2012-09-17 08:13:00 EDT
selinux-policy-3.10.0-149.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-149.fc17
Comment 8 Fedora Update System 2012-09-18 22:54:38 EDT
Package selinux-policy-3.10.0-149.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-149.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14301/selinux-policy-3.10.0-149.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-21 19:58:47 EDT
selinux-policy-3.10.0-149.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.