Bug 850527 - NPE in Drift after import of plugins
NPE in Drift after import of plugins
Status: CLOSED DUPLICATE of bug 850572
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.5
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 14:40 EDT by Heiko W. Rupp
Modified: 2012-08-27 11:24 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 11:24:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2012-08-21 14:40:12 EDT
Imported a cron server type (and others) got this on console:

14:30:20,979 WARN  [DiscoveryBossBean] Could not perform commit synchronization with agent for server [Cron]
java.lang.RuntimeException: java.lang.NullPointerException
	at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1145)
	at org.rhq.core.pc.inventory.InventoryManager.synchronizeInventory(InventoryManager.java:2188)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.rhq.enterprise.communications.command.impl.remotepojo.server.RemotePojoInvocationCommandService.execute(RemotePojoInvocationCommandService.java:184)

	at $Proxy0.execute(Unknown Source)
	at org.rhq.enterprise.communications.command.server.CommandProcessor.handleIncomingInvocationRequest(CommandProcessor.java:290)
	at org.rhq.enterprise.communications.command.server.CommandProcessor.invoke(CommandProcessor.java:184)
	at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:809)
Caused by: java.lang.NullPointerException
	at org.rhq.enterprise.server.drift.DriftServerServiceImpl.getDriftDefinitions(DriftServerServiceImpl.java:93)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
14:30:21,026 WARN  [DiscoveryBossBean] Could not perform commit synchronization with agent for server [pattern]
java.lang.RuntimeException: java.lang.NullPointerException
	at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1145)
	at org.rhq.core.pc.inventory.InventoryManager.synchronizeInventory(InventoryManager.java:2188)

Caused by: java.lang.NullPointerException
	at org.rhq.enterprise.server.drift.DriftServerServiceImpl.getDriftDefinitions(DriftServerServiceImpl.java:93)


and so on
Comment 1 Heiko W. Rupp 2012-08-21 14:44:06 EDT
Note, that I can't reproduce it on purpose.
Comment 2 Heiko W. Rupp 2012-08-27 11:24:11 EDT

*** This bug has been marked as a duplicate of bug 850572 ***

Note You need to log in before you can comment on or make changes to this bug.