Bug 850539 - [abrt] ibus-1.4.99.20120712-1.fc17: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.99.20120712-1.fc17: Process /usr/bin/ibus-daemon was killed b...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:75db545dfce1b8ef1c186df1d5b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 15:12 EDT by Gaston Cocco
Modified: 2012-10-16 03:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 22:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (4.47 KB, text/plain)
2012-08-21 15:12 EDT, Gaston Cocco
no flags Details
File: backtrace (22.56 KB, text/plain)
2012-08-21 15:12 EDT, Gaston Cocco
no flags Details
File: maps (8.96 KB, text/plain)
2012-08-21 15:12 EDT, Gaston Cocco
no flags Details

  None (edit)
Description Gaston Cocco 2012-08-21 15:12:03 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
crash_function: bus_dbus_impl_dispatch_message_by_rule
executable:     /usr/bin/ibus-daemon
kernel:         3.5.1-1.fc17.x86_64
pid:            1704
pwd:            /tmp
remote_result:  766234
time:           lun 20 ago 2012 08:03:22 ART
uid:            1001
username:       galco
var_log_messages: Aug 20 08:03:23 notebook abrt[2898]: Saved core dump of pid 1704 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2012-08-20-08:03:22-1704 (54693888 bytes)

backtrace:      Text file, 23105 bytes
event_log:      Text file, 4577 bytes
maps:           Text file, 9174 bytes

build_ids:
:da0831cf9c551543fbc94e797a102a57a30e790f
:61e097b3bb0aa9f19ed915d3848285fa293df288
:67792c148d2b8f13f6732c9367e926c26d7376c5
:6086bff484a49cc8b80cb714d7e83a6391394800
:726a299098b7695fc69d788f6b19468810c1ba6e
:b26a3acffde6a14576fe8b9bb2b73ff461f310b6
:e94902364164698b4b22ec38e04d7a03964a0989
:822e9b3523e8312240f41a25722d539bc77ed436
:f4c064df8745dff15466d705fb049138f9a5c949
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881
:6668de624a10d486a3484d5b4921f87b1e77d36c
:8c083e0f61deb55917e5c7b193fe4d000a7375f1
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5
:fb86c3a448f22bd68843d5aa0b35e74d20629e85
:7c35310fc506498c612d5d982ab03becc4b4817c
:d0ff5c635b9991ff9c996523d2a8eefbabe0bf5b
:3ea0c78ee76a42aad427ac089a4771284722c837

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/galco/1

core_backtrace:
:61e097b3bb0aa9f19ed915d3848285fa293df288 0x35925 raise libc.so.6 -
:61e097b3bb0aa9f19ed915d3848285fa293df288 0x370d8 abort libc.so.6 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x68827 g_assertion_message libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x68d44 g_assertion_message_expr libglib-2.0.so.0 -
:3ea0c78ee76a42aad427ac089a4771284722c837 0x9e81 - [exe] -
:3ea0c78ee76a42aad427ac089a4771284722c837 0xa1c7 - [exe] -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xb5aff - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcace9 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcb0f7 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0x6cfb7 g_simple_async_result_complete libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcabf5 - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaeaf - libgio-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xcaf59 - libgio-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47695 g_main_context_dispatch libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x479c8 - libglib-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x47dc2 g_main_loop_run libglib-2.0.so.0 -
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5 0xc9466 - libgio-2.0.so.0 -
:8c083e0f61deb55917e5c7b193fe4d000a7375f1 0x6a305 - libglib-2.0.so.0 -
:6086bff484a49cc8b80cb714d7e83a6391394800 0x7d14 start_thread libpthread.so.0 -
:61e097b3bb0aa9f19ed915d3848285fa293df288 0xf0d2d clone libc.so.6 -

dso_list:
:/usr/lib64/libgobject-2.0.so.0.3200.4 glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc17.x86_64 (Fedora Project) 1339766401
:/usr/lib64/libglib-2.0.so.0.3200.4 glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/lib/locale/locale-archive glibc-common-2.15-54.fc17.x86_64 (Fedora Project) 1345114708
:/usr/lib64/libgthread-2.0.so.0.3200.4 glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/lib64/gconv/gconv-modules.cache glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/libc-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/libgio-2.0.so.0.3200.4 glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-2.fc17.x86_64 (Fedora Project) 1339766407
:/usr/lib64/libselinux.so.1 libselinux-2.1.10-3.fc17.x86_64 (Fedora Project) 1339766400
:/usr/share/locale/es/LC_MESSAGES/glib20.mo glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/share/locale/es/LC_MESSAGES/glib20.mo glib2-2.32.4-1.fc17.i686 (Fedora Project) 1343940380
:/usr/lib64/libibus-1.0.so.5.0.499 ibus-libs-1.4.99.20120712-1.fc17.x86_64 (Fedora Project) 1343941314
:/usr/lib64/libnss_files-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/librt-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/libresolv-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/ld-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/share/locale/es/LC_MESSAGES/libc.mo glibc-common-2.15-54.fc17.x86_64 (Fedora Project) 1345114708
:/usr/bin/ibus-daemon ibus-1.4.99.20120712-1.fc17.x86_64 (Fedora Project) 1343941317
:/usr/lib64/libgmodule-2.0.so.0.3200.4 glib2-2.32.4-1.fc17.x86_64 (Fedora Project) 1343212460
:/usr/lib64/libdl-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716
:/usr/lib64/libpthread-2.15.so glibc-2.15-54.fc17.x86_64 (Fedora Project) 1345114716

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-5dlCDFkuAD,guid=0c5129dd3e92d4cec35c031d00000056
:XDM_MANAGED=method=classic
:XDG_RUNTIME_DIR=/run/user/galco
:DISPLAY=:0
:DESKTOP_SESSION=default
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/games
:XDG_VTNR=1
:DM_CONTROL=/var/run/xdmctl
:XDG_SESSION_ID=1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-5dlCDFkuAD,guid=0c5129dd3e92d4cec35c031d00000056
:XDG_SEAT=seat0
:XAUTHORITY=/tmp/.XauthMLBVkb
:USER=galco
:DBUS_STARTER_BUS_TYPE=session
:SHLVL=1
:PWD=/home/galco
:LANG=es_AR.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=galco
:HOME=/home/galco
:LC_CTYPE=es_AR.UTF-8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15308                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15308                15308                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:pipe:[23595]
:pos:	0
:flags:	01
:2:pipe:[23596]
:pos:	0
:flags:	01
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:socket:[23801]
:pos:	0
:flags:	02004002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[23804]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[23008]
:pos:	0
:flags:	02004002
:11:socket:[23009]
:pos:	0
:flags:	02004002
:12:socket:[23010]
:pos:	0
:flags:	02004002
:13:socket:[23011]
:pos:	0
:flags:	02004002
:14:socket:[23012]
:pos:	0
:flags:	02004002
:15:socket:[23013]
:pos:	0
:flags:	02004002
:16:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:17:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:18:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:19:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:20:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:21:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:22:socket:[23018]
:pos:	0
:flags:	02004002
:23:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:General
:=================================
:UUID: 3fd00ee2-7df5-421a-91c3-c8f949ac9318
:SO: Fedora release 17 (Beefy Miracle)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_AR.UTF-8
:Plataforma: x86_64
:BogoMIPS: 4189.57
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz
:Paso del UCP: 10
:Familia de UCP: 6
:Número de Modelo de CPU: 23
:Número de CPUs: 2
:Velocidad del CPU: 2100
:Memoria del Sistema: 1934
:Intercambio (swap) del Sistema: 3871
:Vendedor: Hewlett-Packard
:Sistema: Compaq Presario CQ40 Notebook PC 0490130000200D10000010000
:Factor de forma: Notebook
:Kernel: 3.5.1-1.fc17.x86_64
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(32902:9288:4156:13831) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10816:4156:13831) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:4156:13831) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4156:13831) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4156:13831) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:10564:4156:13831) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(5348:17173:4156:5384) pci, wl, NETWORK, BCM4312 802.11b/g LP-PHY
:(32902:10566:4156:13831) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:4156:13831) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4156:13831) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10550:4156:13831) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4156:13831) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4156:13831) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(4332:33078:4156:12535) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10818:4156:13831) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4156:13831) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:4156:13831) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:4156:13831) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4156:13831) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4156:13831) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4156:13831) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10570:4156:13831) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_notebook-lv_root / ext4 4096 4096 8563132 996491 561496 2179072 1964083 1964083
:/dev/sda6 /boot ext4 1024 1024 495844 398648 373048 128016 127665 127665
:
Comment 1 Gaston Cocco 2012-08-21 15:12:07 EDT
Created attachment 606025 [details]
File: event_log
Comment 2 Gaston Cocco 2012-08-21 15:12:11 EDT
Created attachment 606026 [details]
File: backtrace
Comment 3 Gaston Cocco 2012-08-21 15:12:13 EDT
Created attachment 606027 [details]
File: maps
Comment 4 fujiwara 2012-08-23 04:35:27 EDT
> #1  0x0000003fa20370d8 in abort () from /lib64/libc.so.6
> No symbol table info available.
From your backtrace, the "BUS_IS_CONNECTION (skip_connection)" was failed.
But I cannot reproduce your problem.
Are you still able to see your problem?


> #2  0x0000003fa4468827 in g_assertion_message (domain=domain@entry=0x419773 "IBUS", file=file@entry=0x419c43 "dbusimpl.c", line=line@entry=1886, func=func@entry=0x41af80 "bus_dbus_impl_dispatch_message_by_rule", message=<optimized out>) at gtestutils.c:1861
>         lstr = "1886\000\177\000\000\340AQ\327\026\177\000\000\000\001S\001\000\000\000\000\030\240A\000\000\000\000"
>         s = 0x7f16c801dc00 "\360+\002\310\026\177"
> #3  0x0000003fa4468d44 in g_assertion_message_expr (domain=domain@entry=0x419773 "IBUS", file=file@entry=0x419c43 "dbusimpl.c", line=line@entry=1886, func=func@entry=0x41af80 "bus_dbus_impl_dispatch_message_by_rule", expr=expr@entry=0x41a018 "skip_connection == NULL || BUS_IS_CONNECTION (skip_connection)") at gtestutils.c:1872
>         s = <optimized out>
> #4  0x0000000000409e81 in bus_dbus_impl_dispatch_message_by_rule (dbus=dbus@entry=0x14c9010, message=message@entry=0x162b4f0, skip_connection=skip_connection@entry=0x7f16c801cf60) at dbusimpl.c:1886
>         __PRETTY_FUNCTION__ = "bus_dbus_impl_dispatch_message_by_rule"
>         dispatched_quark = 272
>         is_running = <optimized out>
> #5  0x000000000040a1c7 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x162b4f0, incoming=<optimized out>, user_data=0x14c9010) at dbusimpl.c:1563
>         __PRETTY_FUNCTION__ = "bus_dbus_impl_connection_filter_cb"
>         dbus = 0x14c9010
>         connection = 0x7f16c801cf60
Comment 5 diakula 2012-10-16 03:20:15 EDT
I've applied some Fedora updates, and after that have not seen this in the past few days. I'll notify if this happens again.

Thanks for the quick reaction!

Note You need to log in before you can comment on or make changes to this bug.