Bug 850550 - TypeError: verifyLocalPkg() takes exactly 1 argument (2 given)
TypeError: verifyLocalPkg() takes exactly 1 argument (2 given)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Alpha/F18AlphaBlocker 852272
  Show dependency treegraph
 
Reported: 2012-08-21 16:01 EDT by Brian Lane
Modified: 2014-01-21 18:23 EST (History)
10 users (show)

See Also:
Fixed In Version: yum-3.4.3-33.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 20:30:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2012-08-21 16:01:40 EDT
anaconda 18.7 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 988, in _run_callback
    return cb(obj, *arg, **karg)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1120, in retryfunc
    _run_callback(opts.checkfunc, obj)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1020, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1126, in urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 402, in _mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 424, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 909, in _getFile
    **kwargs
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 941, in getPackage
    **kwargs
  File "/tmp/updates/pyanaconda/packaging/yumpayload.py", line 1294, in callback
    package_path = repo.getPackage(txmbr.po)
TypeError: verifyLocalPkg() takes exactly 1 argument (2 given)


A change in yumRepo.py getPackage() is causing this error.

931         if checkfunc is None:
932             checkfunc = (package.verifyLocalPkg, (), {})

package.verifyLocalPkg only takes self, no additional args.

I used yum-3.4.3-32.fc18.noarch for this build of the installer.
Comment 1 Adam Williamson 2012-08-21 20:06:35 EDT
Note: this bug is effectively blocking F18 Alpha.

anaconda team has adjusted anaconda for the new groups stuff introduced in yum-3.4.3-32.fc18, so any new anaconda build would be useless unless a yum with that change introduced is also included. But we probably don't want to take a yum with this bug in it into stable. Hence, we really need to get this bug fixed so we have a new yum build that's good enough to push stable and include in new Alpha composes, so we can push new anaconda builds which rely on this new yum. Hope that's vaguely clear. tl;dr summary: please fix this yesterday :)
Comment 2 Fedora Update System 2012-08-22 09:13:51 EDT
yum-3.4.3-33.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-12179/yum-3.4.3-33.fc18
Comment 3 Kamil Páral 2012-08-22 09:26:38 EDT
This should be ON_QA then.
Comment 4 Adam Williamson 2012-08-22 12:29:42 EDT
Discussed at 2012-08-22 blocker review meeting, accepted as a blocker per criterion "The installer must be able to complete package installation with the default package set for each supported installation method".
Comment 5 Fedora Update System 2012-08-27 06:53:05 EDT
yum-3.4.3-34.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-34.fc18
Comment 6 Fedora Update System 2012-08-28 19:35:16 EDT
yum-3.4.3-36.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-3.4.3-36.fc18
Comment 7 Kamil Páral 2012-09-03 04:48:17 EDT
What's the reproducer? How can I check in Alpha TC5?
Comment 8 Zdeněk Pavlas 2012-09-03 06:03:30 EDT
See BZ 681224.
Comment 9 Kamil Páral 2012-09-04 07:05:20 EDT
(In reply to comment #8)
> See BZ 681224.

Sorry, either the bug number is wrong or I don't understand it. But I need someone to verify the problem is fixed or tell me how I can verify it.
Comment 10 Kamil Páral 2012-09-04 10:12:36 EDT
Zdeněk says (over IRC) that if the installation works, this bug is fixed. Marking as such.
Comment 11 Adam Williamson 2012-09-05 20:30:04 EDT
yum-3.4.3-40.fc18 was pushed stable, so we can close this.

Note You need to log in before you can comment on or make changes to this bug.