Bug 850566 - [RFE] Expired/Expiring Subscriptions Improvements
[RFE] Expired/Expiring Subscriptions Improvements
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
: FutureFeature
Depends On:
Blocks: rhsm-rhel71
  Show dependency treegraph
 
Reported: 2012-08-21 16:34 EDT by Matt Reid
Modified: 2014-01-17 13:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 13:00:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-08-21 16:34:56 EDT
Description of problem:

Currently if someone has a subscription expire on them, and they go to My Installed Products, they'll see the generic "you have a product without a subscription" message. It'd be nicer if we instead showed a custom string that says they had a subscription expire. 

We should also include a status message for expiring subscriptions.

I'd like to talk about how we handle expired subscriptions as well, I'm not sure blanking all data in the table except for saying "Expired" is the best approach, it could be useful to keep the dates there, so they easily know how long ago the subscription expired. It could be beneficial to keep the expired cert around until either they attach a new subscription, or x days have gone by, rather than automatically cleaning up the cert on the next check-in.


Expired Strings:
"1 subscription expired."
"2 subscriptions expired."

Expiring Strings:
"1 subscription expiring."
"2 subscriptions expiring."

Then they could glance down at the table and see when they expired by looking at the date ranges, and click on the subscription for potentially more information.

Matches up with Backlog item - US22516
Comment 2 Tom Lavigne 2012-09-07 11:25:52 EDT
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Since we are unable to provide this feature at this time,  
it has been proposed for the next release of 
Red Hat Enterprise Linux.
Comment 3 Bryan Kearney 2012-09-10 12:40:43 EDT
We should be able to get this in for 6.4.
Comment 4 Tom Lavigne 2012-09-18 11:51:04 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Since Red Hat is unable to address this request at this time, 
it has been proposed for the next release of Red Hat Enterprise 
Linux.
Comment 5 Carter Kozak 2014-01-17 13:00:43 EST
It is very hard to tell what is expired from the client, because expired certs get cleaned up.

Note You need to log in before you can comment on or make changes to this bug.