Bug 850643 - Environment variable PS1 is changed after removing postgresql from a scalable app.
Environment variable PS1 is changed after removing postgresql from a scalable...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 01:12 EDT by Jianwei Hou
Modified: 2015-05-14 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: devenv_2064+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-08-22 01:12:06 EDT
Description of problem:
Environment variable PS1 was changed after posrgresql was removed from a scalable app.

Version-Release number of selected component (if applicable):
on devenv_2047, on INT

How reproducible:
Always

Steps to Reproduce:
1.Create a scalable app and embed postgresql
2.ssh into app, run 'env' command, and check PS1 variable, then logout
  PS1=[php2s-2047t1.dev.rhcloud.com \W]\>
3.remove postgresql from app
4.ssh into app again, run 'env' command, and check PS1 variable again
  PS1=[ \W]\>
  
Actual results:
hjw@my ~$ ssh da577fcb643a4da1b95a2ea96839a096@php2s-2047t1.dev.rhcloud.com

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://openshift.redhat.com/app/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app destroy'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

[ ~]\> 

After ssh into app again, PS1 was changed to [ \W]\>


Expected results:
PS1 should not be changed, and should be like: [php2s-2047t1.dev.rhcloud.com ~]\> 

Additional info:
After embedding postgresql again, the modified PS1 is not changed back.
Comment 1 Dan Mace 2012-08-23 16:41:23 EDT
Seems to be already fixed in devenv_2064+.
Comment 2 Jianwei Hou 2012-08-24 02:28:08 EDT
Verified on devenv_2068

1.Create a scalable app with postgresql embedded
2.ssh into app, and check $PS1([php1s-2068t1.dev.rhcloud.com ~])
3.Remove postgresql from scalable app
4.ssh into app agian, and check $PS1

Result:
PS1 remains unchanged.
[php1s-2068t1.dev.rhcloud.com ~]\>

Note You need to log in before you can comment on or make changes to this bug.