Bug 850653 - kdm don't work with F18 rawhide
kdm don't work with F18 rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chitlesh GOORAH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 02:15 EDT by dominique
Modified: 2012-08-23 07:24 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 07:24:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dominique 2012-08-22 02:15:32 EDT
Description of problem:
I test rawhide F18, and I use KDE.
And I use also kdm instead of gdm.

For that I just create desktop file in /etc/sysconfig with line "DISPLAYMANAGER=KDE" in it.

That work for all fedora release, but with F18 rawhide, that don't work and I have gdm as display manager.

Where is the problem ?

Additional comment :
I install F18 rawhide by update tgo F17 (by enable rawhide repo), and I have kdm 
first, but since one month, that don't work and I have gdm.
Comment 1 Martin Bříza 2012-08-22 04:28:56 EDT
Hello,

This is due to the https://fedoraproject.org/wiki/Features/DisplayManagerRework .
The default login manager is no longer set with the DISPLAYMANAGER variable.
I think editing /usr/lib/systemd/system-preset/99-default.preset and replacing enable gdm.service with enable kdm.service should set kdm as default.
However, I'm not yet exactly sure if this solution is absolutely right as one can enable kdm with "systemctl enable --force kdm.service", yet I don't know if this change is then permanent or just one-time.

This all is true only if you have at least kde-settings 4.9-1 installed. And please, are you using rawhide or Fedora 18? There is a difference now, Fedora 18 branched from rawhide about two weeks ago.

I'd love to test that for you but my Fedora 18 is now in not exactly perfect state as I have installed it using black magic and it refuses to start X automatically.
Comment 2 dominique 2012-08-22 08:45:33 EDT
Thank for your reply.
I read the link, and after I do that (in root):
 systemctl disable gdm.service
 systemctl enable kdm.service

And after reboot, I have kdm as display manager.

I reboot three time, and that work...

It's not a bug, but a feature...

Can you close this bug ?
Comment 3 dominique 2012-08-22 14:19:08 EDT
For info, I'm not with rawhide but with F18...
Comment 4 Martin Bříza 2012-08-23 07:24:46 EDT
Thank you for the information. Closing the report as it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.