Bug 850738 - If any object is displayed to admin@internal once, it doesn't disappear when rights on the object are removed
If any object is displayed to admin@internal once, it doesn't disappear when ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
infra
:
Depends On:
Blocks: 804248
  Show dependency treegraph
 
Reported: 2012-08-22 05:34 EDT by Tomas Dosek
Modified: 2016-02-10 14:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 09:08:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dosek 2012-08-22 05:34:50 EDT
Description of problem:
Default behaviour of User portal is not to display admin user any object unless another rughts (than SuperUser inherited) are given to admin user on the object.

Following scenario below I was able to simulate a state when object persists in UserPortal of admin user even though that Only inherited SuperUser right was set on it.

Version-Release number of selected component (if applicable):
si15

How reproducible:
100 %

Steps to Reproduce:
1. Create a pool 1test - grant UserRole Permission on the pool to admin&internal
2. In User Portal run a vm from the pool above using the admin account, connect to the vm
3. Go to webadmin and create second pool 2test and grant UserRole rights to the pool again to admin@internal
4. In User Portal run a vm from the pool 2test and conncet to it
5. Remove UserRole from the pool 1test
6. Reload User Portal
  
Actual results:
1test pool is still available from User Portal and any operation may be done on it

Expected results:
Pool should dissapear - same for any other object (VMs, etc.)
Comment 1 Itamar Heim 2012-08-22 17:38:55 EDT
isn't this because according to bug 850741 the user is still linked to the VM of the pool?
Comment 2 Tomas Dosek 2012-08-23 03:24:59 EDT
Probably not I reproduced it also with VM not only pool VM.
Comment 3 Tomas Dosek 2012-08-23 09:08:52 EDT
Closing as NOTABUG - after cleaning browser's cache I cannot reproduce this.

Note You need to log in before you can comment on or make changes to this bug.