Bug 850779 - Provide an sos plugin for sanlock in order to collect the relevant logs
Provide an sos plugin for sanlock in order to collect the relevant logs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.3
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Federico Simoncelli
David Kutálek
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 08:12 EDT by Gadi Ickowicz
Modified: 2014-08-21 21:41 EDT (History)
15 users (show)

See Also:
Fixed In Version: sos-2.2-32.el6
Doc Type: Bug Fix
Doc Text:
Cause: The sanlock package is a new component that provides disk based leases, and uses the watchdog device to protect their recovery. Consequence: Previous versions of sos did not include support for collecting sanlock diagnostic data. Fix: A new module has been added to collect configuration and log files for this component. Result: Diagnostic information relating to the sanlock service is now captured in generated reports.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:58:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm + spm logs (980.56 KB, application/x-gzip)
2012-08-22 08:12 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-08-22 08:12:35 EDT
Created attachment 606226 [details]
vdsm + spm logs

Description of problem:
on a host that is the SPM, no information is being written to spm-lock.log

Version-Release number of selected component (if applicable):
vdsm-4.9.6-29.0.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
On a host that is SPM, nothing is being written to the log file

vdsm logs and spm-lock.log attached.
Comment 3 Federico Simoncelli 2012-08-22 12:40:30 EDT
As far as I see in the logs the domains were V3 and therefore the logging took place in sanlock (/var/log/sanlock.log). What we may want to do is provide an sos plugin to fetch also the sanlock logs. Renaming the bug accordingly.
Comment 4 Keith Robertson 2012-08-22 12:47:58 EDT
So what application is producing sanlock.log
Comment 5 Federico Simoncelli 2012-08-23 13:41:51 EDT
A patch has been proposed upstream:

commit 12e71c8cfd684ef6ab68c9e19c4cc1abb1dfd62f
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Thu Aug 23 10:08:51 2012 -0400

    sos/plugins: add plugin for sanlock
    
    Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>


https://lists.fedorahosted.org/pipermail/sanlock-devel/2012-August/000262.html
Comment 6 Bryn M. Reeves 2012-08-24 04:39:18 EDT
Thanks for the patch - looks good - I'll add this to the queue for RHEL6. You can also post sos patches to the sos-devel mailing list for review:

http://www.redhat.com/mailman/listinfo/sos-devel

They'll reach a wider audience of sos contributors there than bugzilla.

One thing to check is whether any of the files contain anything that we should elide for security reasons? I don't think so but I'm not very familiar with sanlock so it would be good to get that signed off by someone who knows the package well.
Comment 8 Bryn M. Reeves 2012-10-15 12:25:10 EDT
This is the sanlock helper that provides SCSI-3 PR support for e.g. cluster - patch looks good.
Comment 12 David Teigland 2012-10-19 11:40:55 EDT
The cause here is not correct -- sanlock is not related to scsi3 PR.  It uses disk blocks and two new algorithms to implement cluster leases.  It also uses the watchdog to protect recovery of those leases.  It's been developed for RHEV, but I've also applied it in a minimal fashion to use for fencing in a cluster.

https://fedorahosted.org/sanlock/
http://git.fedorahosted.org/cgit/sanlock.git/plain/fence_sanlock/fence_sanlock.8
Comment 13 Haim 2012-10-28 08:23:36 EDT
verified on sos-2.2-32.el6.noarch:

gold-vdsd-2012102814141351426470/sos_commands/sanlock
gold-vdsd-2012102814141351426470/etc/logrotate.d/sanlock
gold-vdsd-2012102814141351426470/etc/rc.d/init.d/sanlock
gold-vdsd-2012102814141351426470/etc/sysconfig/sanlock
Comment 15 errata-xmlrpc 2013-02-21 05:58:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0474.html

Note You need to log in before you can comment on or make changes to this bug.