Bug 850823 - WinXP vm still uses -device intel-hda,id=sound0,bus=pci.0,addr=0x4
WinXP vm still uses -device intel-hda,id=sound0,bus=pci.0,addr=0x4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Roy Golan
Bill Sanford
virt
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 09:36 EDT by Bill Sanford
Modified: 2015-09-22 09 EDT (History)
12 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the Device Manager with the Intel sound driver and not the AC97 (845.68 KB, image/bmp)
2012-08-22 10:26 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2012-08-22 09:36:31 EDT
Description of problem:
WinXP still uses -device intel-hda,id=sound0,bus=pci.0,addr=0x4 but for WinXp It should be AC97.

Version-Release number of selected component (if applicable):
RHEV-M si14
vdsm-cli-4.9.6-28.0.el6_3.noarch
vdsm-4.9.6-28.0.el6_3.x86_64
vdsm-python-4.9.6-28.0.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
WinXP still uses -device intel-hda

Expected results:
WinXP should use AC97

Additional info:

qemu     32424  4.0 27.4 2656884 2210768 ?     Sl   Aug21  44:32 /usr/libexec/qemu-kvm -S -M rhel6.3.0 -cpu Nehalem -enable-kvm -m 2048 -smp 1,sockets=1,cores=1,threads=1 -name winxp -uuid 534ed537-16d5-402d-baea-264990138170 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.3.0.3.el6,serial=04AE3D25-7E25-1654-257F-54162A3E4EFF_1C:C1:DE:FA:AC:F2,uuid=534ed537-16d5-402d-baea-264990138170 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/winxp.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2012-08-21T18:54:50,driftfix=slew -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/rhev/data-center/1b5da69e-eaec-11e1-99c2-52540053bfec/df6bd6fd-abfa-4aff-a51d-f4e442c7c585/images/c66d8ca3-7bda-4c66-a45c-4be19ffef993/a3794ddf-a94e-474e-8cec-d8628008b5ff,if=none,id=drive-ide0-0-0,format=raw,serial=c66d8ca3-7bda-4c66-a45c-4be19ffef993,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,fd=26,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:1a:4a:10:18:a1,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/winxp.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -chardev pty,id=charconsole0 -device virtconsole,chardev=charconsole0,id=console0 -spice port=5902,tls-port=5903,addr=0,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=main,tls-channel=inputs -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
Comment 1 Michal Skrivanek 2012-08-22 09:44:19 EDT
may be the same issue as in 849635.
Comment 2 Bill Sanford 2012-08-22 09:58:10 EDT
Michal, it might be the same root cause, but that one deals with QXL and not AC97.
Comment 3 Michal Skrivanek 2012-08-22 10:11:40 EDT
yes, and that's why I'm keeping this one still open.
not sure why you've reverted my changes to the bug, though.
Comment 4 Bill Sanford 2012-08-22 10:26:09 EDT
Created attachment 606288 [details]
Screenshot of the Device Manager with the Intel sound driver and not the AC97
Comment 5 Roy Golan 2012-08-23 16:12:22 EDT
should we assign AC97 only when its winXP and use intel for the rest?
Comment 6 Roy Golan 2012-08-23 16:21:53 EDT
Answering myself - I just saw the configuration value DesktopAudioDeviceType per version. 

 222 | DesktopAudioDeviceType | default,ac97                                                                                                                 | 2.2
       238 | DesktopAudioDeviceType | WindowsXP,ac97,RHEL4,ac97,RHEL3,ac97,Windows2003x64,ac97,RHEL4x64,ac97,RHEL3x64,ac97,OtherLinux,ac97,Other,ac97,default,ich6 | 3.0
       304 | DesktopAudioDeviceType | WindowsXP,ac97,RHEL4,ac97,RHEL3,ac97,Windows2003x64,ac97,RHEL4x64,ac97,RHEL3x64,ac97,OtherLinux,ac97,Other,ac97,default,ich6 | 3.1
       382 | DesktopAudioDeviceType | WindowsXP,ac97,RHEL4,ac97,RHEL3,ac97,Windows2003x64,ac97,RHEL4x64,ac97,RHEL3x64,ac97,OtherLinux,ac97,Other,ac97,default,ich6 | 3.2
Comment 7 Roy Golan 2012-08-23 20:56:00 EDT
http://gerrit.ovirt.org/#/c/7451/
Comment 8 Michal Skrivanek 2012-08-24 08:49:58 EDT
confirming this as a different issue from 849635
Comment 9 Eli Mesika 2012-08-26 11:41:04 EDT
fixed in commit : 5399c8e
Comment 11 Bill Sanford 2012-08-30 10:06:53 EDT
Verified in si16.

Note You need to log in before you can comment on or make changes to this bug.