Bug 850841 - Drools application is not autodiscovered by JON
Drools application is not autodiscovered by JON
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- BRMS 5 (Show other bugs)
JON 3.1.1
i386 Linux
high Severity high
: ---
: JON 3.1.2
Assigned To: Simeon Pinder
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 10:14 EDT by Pavel Kralik
Modified: 2013-09-11 06:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 06:59:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
drools-jon-example application (19.03 KB, application/x-gzip)
2012-08-22 10:14 EDT, Pavel Kralik
no flags Details
JON Server and Agent logs (245.03 KB, application/x-gzip)
2012-08-22 10:15 EDT, Pavel Kralik
no flags Details
JON 3.1.1.CR1 DEBUG logs for BRMS 5.2.0 (200.06 KB, application/x-gzip)
2012-09-04 07:41 EDT, Pavel Kralik
no flags Details
JON 3.1.1.CR1 DEBUG logs for BRMS 5.3.0 (223.19 KB, application/x-gzip)
2012-09-04 07:42 EDT, Pavel Kralik
no flags Details

  None (edit)
Description Pavel Kralik 2012-08-22 10:14:34 EDT
Created attachment 606286 [details]
drools-jon-example application

When monitoring the Drools example application (BRMS 5.2.0.GA, BRMS 5.3.0.GA) application with JON 3.1.1, the application is not autodiscovered, can be just manually added for the platform. Monitoring with Jconsole works.

Version-Release number of selected component (if applicable):

BRMS-5.2.0.GA/5.3.0.GA
JON 3.1.1.ER2:
https://brewweb.devel.redhat.com/buildinfo?buildID=228250

How reproducible:

Always

Steps to Reproduce:
1. Install the JON 3.1.1.ER2 server and with the BRMS plugin

2. Run a drools-jon-example application

3. Try to autodiscover the Drools application.

Actual results:

Autodiscovery fails.

Expected results:

The application is discovered.

Additional info:

Steps to get Drools application running:

1) Unpack drools_application.tar.gz
2) Download the BRMS deployable zip file:

BRMS 5.3.0.GA:
http://download.devel.redhat.com/released/JBossBRMS/5.3.0/brms-p-5.3.0.GA-deployable.zip

BRMS 5.2.0.GA:
http://download.devel.redhat.com/released/JBossBRMS/5.2.0/brms-p-5.2.0.GA-deployable.zip

3) unzip brms-p-5.*-deployable.zip
4) unzip jboss-brms-engine.zip
5) Create link from binaries to drools-jon-example/drools
6) Run the application:
     ant compile; ant server
     ant client.phase1; ant client.phase2
7) Try to monitor with Jconsole and JON
Comment 1 Pavel Kralik 2012-08-22 10:15:29 EDT
Created attachment 606287 [details]
JON Server and Agent logs
Comment 2 Charles Crouch 2012-08-24 09:57:49 EDT
Hi Pavel
If the Drools team are going to be able to get to the bottom of the issue, I expect they will need DEBUG level logs from the JON server and agent.
Comment 3 Pavel Kralik 2012-09-04 07:41:45 EDT
Created attachment 609643 [details]
JON 3.1.1.CR1 DEBUG logs for BRMS 5.2.0

JON 3.1.1.CR1:
https://brewweb.devel.redhat.com/buildinfo?buildID=231258
did not fix the bug for BRMS 5.2.0/5.3.0.

Adding JON debug logs.
Comment 4 Pavel Kralik 2012-09-04 07:42:32 EDT
Created attachment 609644 [details]
JON 3.1.1.CR1 DEBUG logs for BRMS 5.3.0

Adding JON debug logs for BRMS 5.3.0
Comment 5 Simeon Pinder 2012-09-10 06:43:28 EDT
Hi Pavel,
Is there a version of the BRMS plugin, prior to 5.2 or 5.3, that this standalone application worked with?  It looks to me like the issue with discovery might be that the application and reproduce steps attached start up the drools application via ant and is confusing RHQ.  

Setting needinfo on pavel for more information.
Comment 6 Pavel Kralik 2012-09-10 07:12:19 EDT
Hi Simeon,

the BRMS 5.1/5.2 worked with JON 3.0.1 just fine. Problems started with JON 3.1.0 and BRMS 5.2/5.3. Please, see: https://bugzilla.redhat.com/show_bug.cgi?id=828191
Comment 7 Simeon Pinder 2012-09-10 08:02:28 EDT
Ok. That helps. The earlier e-mail thread that I was forwarded regarding this issue said that this was an issue between JON 3.1.0.GA and 3.1.1.RC which didn't make a lot of sense because I still saw the same issue with 3.1.0.GA and there were no changes in the related code between those releases.

>>
>> It is regression from jon310. It is BRMS 5.2/5.3 problem, not SOA-P.
>>
>> And we believe that this is a BRMS bug? That is - a BRMS-related JON
>> plugin bug, right? (Charles????)

A regression since 3.0.1 makes a bit more sense. Let me update you in a bit.
Comment 8 Simeon Pinder 2012-09-10 09:06:37 EDT
This is a regression. Looks to be a functional one caused by fixes for issues reported while accessing some secure JMX servers.  Working on a fix now.
Comment 10 Pavel Kralik 2012-09-11 04:25:25 EDT
This bug was reported in JON 3.1.0:

Autodiscovery for Drools application does not work
https://bugzilla.redhat.com/show_bug.cgi?id=828191

and it was a part of the Root Cause Analysis BZ 828191 and 828464
http://pad.engineering.redhat.com/RCA-828191-828464

discovered in JON 3.1.0.ER4 build. 828191 was closed as:

https://bugzilla.redhat.com/show_bug.cgi?id=828191#c8
Comment 11 Simeon Pinder 2012-09-11 18:35:54 EDT
This has been fixed in master.  The issue was that the code assumed that the main class for the JMX server would always be listed in the process listing which is not always the case as when the process description is truncated, for example. See https://bugzilla.redhat.com/show_bug.cgi?id=839087 for more details.

This will be fixed in the next JON release, likely 3.1.2 or later.
Comment 13 Simeon Pinder 2012-11-30 15:44:01 EST
This is checked into the release/jon3.1.x branch with commits:
fbb56423a291d67900
10b02ff05c15e2cdf3

See BZ(https://bugzilla.redhat.com/show_bug.cgi?id=839087) for original commits and details description.

Moving this to MODIFIED awaiting a new ER build.
Comment 14 Simeon Pinder 2012-12-07 01:31:33 EST
Moving to ON_QA as available for testing in ER3 or greater: https://brewweb.devel.redhat.com/buildinfo?buildID=246689
Comment 15 Pavel Kralik 2012-12-12 10:14:25 EST
Verified. JON 3.1.2.ER4 and BRMS 5.2.0.GA/5.3.0.GA/5.3.1.CR1.

Note You need to log in before you can comment on or make changes to this bug.