Bug 850861 - ctdb+systemd problems
ctdb+systemd problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ctdb (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sumit Bose
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 10:53 EDT by Jeff Layton
Modified: 2014-06-18 03:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 01:07:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch: fix up systemd integration goop (1.96 KB, patch)
2012-08-22 11:52 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2012-08-22 10:53:37 EDT
There are a number of problems with the ctdb.service file:

1) it defines a PIDFile= directive, but ctdb doesn't create any sort of pidfile there. This makes the startup via systemd fail. Commenting that directive out works, but you probably need to think about how this should be monitored?

2) There is a problem with quoting in the /etc/ctdb/systemd/ctdb.systemd file. The "exec" line has $CTDB_OPTIONS in quotes, which makes it pass the whole thing as one giant argument. Those quotes need to be removed.

3) the startstop_nfslock() function in "functions" probably also needs updating for systemd-ized machines. Still looking at that piece.

Patches forthcoming...
Comment 1 Jeff Layton 2012-08-22 11:52:35 EDT
Created attachment 606315 [details]
patch: fix up systemd integration goop
Comment 2 Jeff Layton 2012-08-22 11:54:11 EDT
Comment on attachment 606315 [details]
patch: fix up systemd integration goop

This patch should fix most of the issues so that ctdb can at least start properly now. I've not touched the NFS integration parts yet, since I have my doubts as to whether that's safe anyway...
Comment 3 Fedora Update System 2012-09-05 06:32:52 EDT
ctdb-1.2.39-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ctdb-1.2.39-5.fc18
Comment 4 Fedora Update System 2012-09-23 01:07:23 EDT
ctdb-1.2.39-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.