Bug 850912 - RFE: support updateinfo
RFE: support updateinfo
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Holy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1066867 1086288 1101029 1109915 1121946
  Show dependency treegraph
 
Reported: 2012-08-22 13:15 EDT by David Jaša
Modified: 2015-10-05 22:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-0.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-12 03:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-08-22 13:15:45 EDT
Description of problem:
add "yum whatsnew" (or similar) command to display changelog since installed version.

I hope this is self-explanatig, the use case is to find out what has changed in components where admin should be wary about any changes - for example you could use "yum whatsnew kernel" to find out if you have to update it and reboot ASAP or if it can wait for some more suitable time.
Comment 1 Ales Kozumplik 2012-08-29 07:07:33 EDT
This is a nice idea, the only thing preventing me from implementing now is there's yet no support for parsing other.xml in libsolv (the repodata file containing the changelogs). Yum in fact does already parse and understand this data, but not exaclty in the manner you suggest here.

Let's keep this open until we can parse other.xml (or decide we will never do that).
Comment 2 Ales Kozumplik 2013-12-17 11:20:59 EST
David, how does what you propose differ from yum's updateinfo?
Comment 3 David Jaša 2013-12-17 11:26:01 EST
(In reply to Ales Kozumplik from comment #2)
> David, how does what you propose differ from yum's updateinfo?

I was not aware of updateinfo at the time of bug filing. If dnf already supports that (I didn't look at dnf for quite a long time), consider this fixed. :)
Comment 4 Ales Kozumplik 2013-12-19 02:48:32 EST
It is not supported yet but I just wanted to make sure whether you're asking for something else.

Radek can you please take a look at this? There is support built in C hawkey for it already---hy_package_get_update*() so all that is left is adding the Python bindings (with which I can help) and integrating in DNF.

Note You need to log in before you can comment on or make changes to this bug.