Bug 850935 - /etc/katello/client.conf is provided by multiple packages
/etc/katello/client.conf is provided by multiple packages
Status: CLOSED UPSTREAM
Product: Katello
Classification: Community
Component: Packaging (Show other bugs)
1.1
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 15:32 EDT by Eric Sammons
Modified: 2012-10-29 10:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 10:32:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-08-22 15:32:40 EDT
Description of problem:
/etc/katello/client.conf is being provided by katello-cli, katello-cli-headpin, and katello-cli-common.  Because the file is required by katello-cli-headpin and katello-cli it seems that the file should only be provided in the katello-cli-common package.

Version-Release number of selected component (if applicable):
katello-cli-headpin-1.1.0-1.git.14.d10e8a3.fc16.noarch


Steps to Reproduce:
1. yum install katello-headpin-all
  
Actual results:

Transaction Check Error:
  file /etc/katello/client.conf conflicts between attempted installs of katello-cli-headpin-1.1.0-1.git.14.d10e8a3.fc16.noarch and katello-cli-common-1.1.2-1.git.162.09c0162.fc16.noarch


Additional info:


# yum whatprovides /etc/katello/client.conf
Loaded plugins: langpacks, presto, refresh-packagekit
katello-cli-1.1.2-1.git.162.09c0162.fc16.noarch : Client package for managing
     ...: application life-cycle for Linux systems
Repo        : katello
Matched from:
Filename    : /etc/katello/client.conf



katello-cli-common-1.1.2-1.git.162.09c0162.fc16.noarch : Common Katello client
                                                       : bits
Repo        : katello
Matched from:
Filename    : /etc/katello/client.conf



katello-cli-headpin-1.1.0-1.git.14.d10e8a3.fc16.noarch : Client package for
     ...: managing a katello-headpin installation
Repo        : katello
Matched from:
Filename    : /etc/katello/client.conf
Comment 1 Miroslav Suchý 2012-08-22 15:52:52 EDT
Taking.

This bug could not be redproduced in CFSE, switching to Katello.

client.conf was include in katello-cli-common by mistake. This package should own only directory /etc/katello, but not its content. And one of the reason is that headpin and katello have diferent content of client.conf.
Comment 2 Miroslav Suchý 2012-08-22 16:02:57 EDT
https://github.com/Katello/katello/pull/502
Comment 3 Miroslav Suchý 2012-08-24 16:44:20 EDT
Fixed in katello.git
* | | | |   1388496 Merge pull request #502 from xsuchy/pull-req-bz850935
| * | | | b4a6828 (fork/pull-req-bz850935) 850935 - katello-cli-common should own only /etc/katello and not its content
Comment 4 Mike McCune 2012-10-24 11:27:38 EDT
feel free to close this since Katello 1.1 has been released
Comment 5 Lukas Zapletal 2012-10-29 10:32:35 EDT
Part of Katello 1.1 release

Note You need to log in before you can comment on or make changes to this bug.