Bug 850952 - tycho 0.16 not finding artifacts in a previous build
tycho 0.16 not finding artifacts in a previous build
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tycho (Show other bugs)
18
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 16:53 EDT by Orion Poplawski
Modified: 2012-08-22 18:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 18:25:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2012-08-22 16:53:16 EDT
Description of problem:

With tycho 0.16 in F18 or rawhide, my eclipse-ptp build fails with:

[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed: org.eclipse.ptp.rdt.sync.ui.fortran 1.0.0.qualifier
[ERROR]   Missing requirement: org.eclipse.ptp.rdt.sync.ui.fortran 1.0.0.qualifier requires 'bundle org.eclipse.photran.cdtinterface 7.0.0' but it could not be found
[ERROR] 
[ERROR] Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.eclipse.ptp.rdt.sync.ui.fortran 1.0.0.qualifier to bundle org.eclipse.photran.cdtinterface 7.0.0.", "No solution found because the problem is unsatisfiable."] -> [Help 1]

This should be found in the just completed build of org.eclipse.photran in a parallel directory.  This seems to work fine with tycho-0.15.0-4.fc17.noarch.

Version-Release number of selected component (if applicable):
0.16.0-4.df2c35.fc18
Comment 1 Orion Poplawski 2012-08-22 17:03:29 EDT
Okay, I lied in saying that it worked in f17.  That was only because I had installed the eclipse-photran packages locally.  Can this be done with tycho?
Comment 2 Roland Grunberg 2012-08-22 17:43:04 EDT
I'll look into this. My first guess would be to look at the contents of the local system p2 repository (.m2/p2/repo/plugins relative to where you ran mvn-rpmbuild) after the build failure.  The plugins you need from the local system should all be there (eg. org.eclipse.photran.cdtinterface). If not, then this would be an issue with how the p2 repository is created. If they're all inside that folder, then something else is happening.

I've done just a quick investigation now, and on my f18 vm, when I create the p2 repo (as Fedora Tycho would),  org.eclipse.photran.cdtinterface is being added : "org.eclipse.photran.cdtinterface=8.0.0.201203151905" and  "org.eclipse.photran.cdtinterface=8.0.0.201203201256".

I noticed that eclipse-photran installs 2 sets of jars in %{_javadir}/eclipse/dropins/org.eclipse.photran/plugins that seem to differ only in qualifier. I'm not sure if that's causing the issue but it seems a bit strange.

Can you post the spec/source/etc ? files needed to reproduce the build (I'm guessing it's no committed yet)
Comment 3 Orion Poplawski 2012-08-22 17:50:20 EDT
http://www.cora.nwra.com/~orion/fedora/eclipse-ptp-6.0.1-1.fc17.src.rpm

I'll try to take a look myself a little later.  Thanks!
Comment 4 Orion Poplawski 2012-08-22 18:25:59 EDT
Looks like I needed to do:

mvn-rpmbuild -Dmaven.repo.local=../.m2

since I'm building in parallel directories.

Note You need to log in before you can comment on or make changes to this bug.