Bug 851096 - s390.sh - incorrect syntax of equation
Summary: s390.sh - incorrect syntax of equation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils
Version: 5.8
Hardware: s390
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Dan Horák
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-23 08:55 UTC by Branislav Náter
Modified: 2013-09-30 23:19 UTC (History)
3 users (show)

Fixed In Version: s390utils-1.8.1-18.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-30 23:19:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1335 normal SHIPPED_LIVE s390utils bug fix update 2013-09-30 21:13:03 UTC

Description Branislav Náter 2012-08-23 08:55:59 UTC
Description of problem:
When starting zsh on s390x architecture, following error message apears:
"/etc/profile.d/s390.sh:4: = not found". This is caused by incorrect syntax of equation in /etc/profile.d/s390.sh script

Version-Release number of selected component (if applicable):
s390utils-1.8.1-17.el5

How reproducible:
always

Steps to Reproduce:
1. start zsh
  
Actual results:
error message "/etc/profile.d/s390.sh:4: = not found"

Expected results:
no error message

Additional info:
"IF" statment in script:

if [ "$contype" == "serial" ]; then

If a word begins with an unquoted `=' and the EQUALS option is set, the remainder of the word is taken as the name of a command...

Correct syntax is:

if [[ "$contype" == "serial" ]]; then #double bracket

OR

if [ "$contype" = "serial" ]; then #single equal signs

Comment 1 RHEL Program Management 2013-04-04 12:37:29 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 6 errata-xmlrpc 2013-09-30 23:19:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1335.html


Note You need to log in before you can comment on or make changes to this bug.