Bug 851128 - rpc.rstatd and rpc.rusersd run as initrc_t
rpc.rstatd and rpc.rusersd run as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
: 811344 (view as bug list)
Depends On:
Blocks: 832330 870603 888164
  Show dependency treegraph
 
Reported: 2012-08-23 06:12 EDT by Milos Malik
Modified: 2013-02-21 03:28 EST (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-160.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870603 888164 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:28:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-08-23 06:12:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):
rusers-server-0.17-61.el6.i686
selinux-policy-3.7.19-155.el6_3.2.noarch
selinux-policy-doc-3.7.19-155.el6_3.2.noarch
selinux-policy-minimum-3.7.19-155.el6_3.2.noarch
selinux-policy-mls-3.7.19-155.el6_3.2.noarch
selinux-policy-targeted-3.7.19-155.el6_3.2.noarch

How reproducible:
always

Steps to Reproduce:
# run_init service rstatd status
Authenticating root.
Password: 
rpc.rstatd is stopped
# run_init service rusersd status
Authenticating root.
Password: 
rpc.rusersd is stopped
# run_init service rstatd start
Authenticating root.
Password: 
Starting rstat services:                                   [  OK  ]
# run_init service rusersd start
Authenticating root.
Password: 
Starting rusers services:                                  [  OK  ]
# ps -efZ | grep initrc_t
system_u:system_r:initrc_t:s0   root      5339     1  0 12:06 ?        00:00:00 rpc.rstatd
system_u:system_r:initrc_t:s0   nobody    5420     1  0 12:09 ?        00:00:00 rpc.rusersd
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 5425 2101  0 12:09 pts/0 00:00:00 grep initrc_t
#
  
Actual results:
* both rpc.statd and rpc.rusersd run as initrc_t

Expected results:
* both rpc.statd and rpc.rusersd run in their own SELinux domains
Comment 1 Miroslav Grepl 2012-08-24 03:52:52 EDT
*** Bug 811344 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2013-02-21 03:28:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.