Bug 851154 - [engine] Unable to remove datacenter because storage domain is stuck on Locked
[engine] Unable to remove datacenter because storage domain is stuck on Locked
Status: CLOSED DUPLICATE of bug 875651
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Linux
unspecified Severity high
: ---
: 3.2.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 07:37 EDT by Gadi Ickowicz
Modified: 2016-02-10 13:49 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 05:26:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm + engine logs (12.48 MB, application/x-gzip)
2012-08-23 07:37 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-08-23 07:37:40 EDT
Created attachment 606515 [details]
vdsm + engine logs

Description of problem:
If storage domain remains locked and unable to remove datacenter (force remove also). After creating a master (iscsi) storage domain, ISO domain and another storage domain (unattached), storage was destroyed on the storage server. At this point removing the datacenter fails, causing  the master storage domain to become locked, and unable to remove using "force remove" either.

Status in database:
engine=# select * from storage_pool;
                  id                  |      name      |       description       | storage_pool_type | storage_pool_format_type | status | master_domain_version | spm_vds_id | compatibility_version |         _crea
te_date          |         _update_date          | quota_enforcement_type
--------------------------------------+----------------+-------------------------+-------------------+--------------------------+--------+-----------------------+------------+-----------------------+--------------
-----------------+-------------------------------+------------------------
 967db7f0-ec5a-11e1-a258-001a4a169705 | Default        | The default Data Center |                 1 |                          |      0 |                     0 |            | 3.1                   | 2012-08-22 16
:09:21.385208+03 | 2012-08-22 16:10:53.310667+03 |
 a23c3ab1-842c-490f-a6a9-15551632e2e2 | TestDataCenter |                         |                 3 | 3                        |      4 |                     1 |            | 3.1                   | 2012-08-23 12
:32:09.175373+03 | 2012-08-23 12:52:09.957153+03 |                      0
(2 rows)

engine=# select * from storage_domains;
                  id                  |                storage                 |   storage_name   |           storage_pool_id            | available_disk_size | used_disk_size | commited_disk_size | status | stora
ge_pool_name | storage_type | storage_domain_type | storage_domain_format_type | last_time_used_as_master | owner | storage_domain_shared_status | recoverable
--------------------------------------+----------------------------------------+------------------+--------------------------------------+---------------------+----------------+--------------------+--------+------
-------------+--------------+---------------------+----------------------------+--------------------------+-------+------------------------------+-------------
 74e9890c-655c-4191-8e2c-ff872b5f87f0 | KEWtvl-0WAl-Q3UP-3De6-LaYI-NxdS-EcTk3L | ISCSIDataDomain2 |                                      |                  45 |              4 |                  0 |        |
             |            3 |                   1 | 3                          |                        0 |       |                            0 | t
 40460dfd-c028-4cda-8413-6c27e0e9e2e0 | AsnhlN-y0kI-I3Nc-qBYs-GU5O-r1vR-dqkeAW | ISCSIDataDomain  | a23c3ab1-842c-490f-a6a9-15551632e2e2 |                     |                |                  0 |      5 | TestD
ataCenter    |            3 |                   1 | 3                          |                        0 |     0 |                            2 | t
 11eae725-0215-47d9-a784-30673a6a0b7c | 82fa2875-82b2-449c-be95-e719ed2e5ba8   | ISODomainRest    | a23c3ab1-842c-490f-a6a9-15551632e2e2 |                     |                |                  0 |      0 | TestD
ataCenter    |            1 |                   2 | 0                          |                        0 |     0 |                            2 | t
(3 rows)



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create and attach master storage domain
2. Create and attach ISO domain
3. Create another storage domain
4. Try to activate the domain without attaching (using REST, fails obviously)
5. Remove storage from storage server 
6. Try to remove datacenter from GUI
  
Actual results:
Master storage domain becomes locked when removing it after the scenario is run

Expected results:
force remove should remove the datacenter

Additional info:
VDSM + engine logs attached
Comment 4 Gadi Ickowicz 2012-11-12 05:26:02 EST

*** This bug has been marked as a duplicate of bug 875651 ***

Note You need to log in before you can comment on or make changes to this bug.