Bug 851184 - [package] Please add/support git (currently in EPEL)
[package] Please add/support git (currently in EPEL)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 08:45 EDT by Jan Pokorný
Modified: 2014-06-30 08:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:21:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2012-08-23 08:45:13 EDT
It would be very helpful to have git package also in RHEL 5,
similarly as it is present in RHEL 6.

My main reason is to be able to use more sensible patch management
when building official packages even for RHEL 5.  Refer to [1].
Currently, git is available at EPEL, which does not help in this
scenario.

I think many others would benefit from this.  Also it comes strange
to me that both cvs and subversion are included in the base channel,
but git, now pretty popular, is sidetracked in EPEL.

Please, consider the significance of git.

[1] http://rwmj.wordpress.com/2011/08/09/nice-rpm-git-patch-management-trick/
Comment 1 Adam Tkac 2012-08-24 04:14:13 EDT
From my point of view it's easy to include git as new RHEL-5 pkg. We can just pick RHEL-6 git and build it for el5.
Comment 2 RHEL Product and Program Management 2012-08-24 06:18:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 Jan Pokorný 2012-08-24 06:38:38 EDT
Perhaps it could be considered for 5.10?
Comment 4 Larry Troan 2013-03-20 15:28:35 EDT
Potential feature requests for RHEL5.10...

Search revealed Bugzillas with following attributes:
* 5.10 mentioned in comments
* STATUS: Not CLOSED
* kEYWORD=FutureFeature
Comment 5 RHEL Product and Program Management 2013-05-01 03:18:16 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2014-03-07 07:51:54 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:21:17 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 8 Jan Pokorný 2014-06-30 08:19:28 EDT
M'kay, EPEL works fine to some extent.

Note You need to log in before you can comment on or make changes to this bug.