Bug 851185 - Missing *.hmac files in FIPS initramfs
Missing *.hmac files in FIPS initramfs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 717789 851504
  Show dependency treegraph
 
Reported: 2012-08-23 08:45 EDT by Milan Broz
Modified: 2013-02-28 23:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 851504 (view as bug list)
Environment:
Last Closed: 2012-09-17 19:29:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from dracut -f -v --debug -a crypt (8.14 MB, text/plain)
2012-08-23 09:14 EDT, Milan Broz
no flags Details
Proposed workaround for dracut-install (2.78 KB, patch)
2012-08-23 13:58 EDT, Milan Broz
no flags Details | Diff
Proposed patch to make fipscheck really work in initramfs (1.21 KB, patch)
2012-08-23 13:59 EDT, Milan Broz
no flags Details | Diff

  None (edit)
Description Milan Broz 2012-08-23 08:45:22 EDT
Description of problem:

Seems that dracut doesn not put FIPS *.hmac filer in initramfs, so fipscheck verification cannot succeed.

Version-Release number of selected component (if applicable):
dracut-023-2.fc18.x86_64

How reproducible:
Easy to test, just install crypt module dracut -f -a crypt and try to run cryptsetup in initramfs "cryptsetup status x" - it will fail with FIPS check failed.
Comment 1 Milan Broz 2012-08-23 08:51:32 EDT
Hm, this should be perhaps F17 bug only and related only to cryptsetup.

I'll post more info ASAP, seems my system is kind of broken now...
Comment 2 Milan Broz 2012-08-23 09:07:18 EDT
I think the problem is that hmac location changes (seems not for all packages though) to /lib/fipscheck:

# ls /lib64/fipscheck
cryptsetup.hmac  fipscheck.hmac  libcryptsetup.so.4.3.0.hmac  libcryptsetup.so.4.hmac  libfipscheck.so.1.1.0.hmac  libfipscheck.so.1.hmac  sshd.hmac  ssh.hmac
Comment 3 Milan Broz 2012-08-23 09:14:15 EDT
Created attachment 606558 [details]
Log from dracut -f -v --debug -a crypt
Comment 4 Milan Broz 2012-08-23 10:07:48 EDT
Hmmm. this change is 2 years old.. I wonder if cryptsetup is the first real user of fipscheck in initramfs? :)
https://fedorahosted.org/fipscheck/changeset/31ef85b2a86e5e696a5dfde4665cfe2c55bb3dae
Comment 5 Milan Broz 2012-08-23 13:58:05 EDT
Created attachment 606673 [details]
Proposed workaround for dracut-install

Proposed (ugly:-) workaround for dracut-install to handle fipscheckdir
Comment 6 Milan Broz 2012-08-23 13:59:20 EDT
Created attachment 606674 [details]
Proposed patch to make fipscheck really work in initramfs

Proposed patch to make fipscheck really work in initramfs.

Similar change was in RHEL6 but somehow disappeared on the way...
Comment 7 Fedora Update System 2012-09-10 10:16:24 EDT
dracut-023-39.git20120910.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dracut-023-39.git20120910.fc18
Comment 8 Fedora Update System 2012-09-10 12:09:42 EDT
Package dracut-023-39.git20120910.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-023-39.git20120910.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13731/dracut-023-39.git20120910.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-17 19:29:39 EDT
dracut-023-39.git20120910.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.