Bug 8512 - Compiler flags
Summary: Compiler flags
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-16 11:28 UTC by Bernhard Rosenkraenzer
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 02:19:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernhard Rosenkraenzer 2000-01-16 11:28:51 UTC
Hi, we're still keeping -fno-strength-reduce in rpmrc for i386. It was useful to work around a breakage of gcc versions prior to 2.7.2.2, but doesn't make any sense today. All it does is slow things down.
I can understand it's still in the base package for people who are stuck with old compilers, but we should get rid of it in our rpm rpm. Also, how about adding something along the lines of optflags: i686 -O2 -mpentiumpro -march=i686?
Cc'ing gafton because the same thing is done in the build roots.

Comment 1 Cristian Gafton 2000-02-04 02:19:59 UTC
Like it or not, these compiler flags have proven to be safe. We're not about to
change that. And I am sure that we'll not be automatically generating i686
binaries only when rpm is running on a i686


Note You need to log in before you can comment on or make changes to this bug.