Bug 851220 - EFI syslinux contains wrong path to kernel pair
EFI syslinux contains wrong path to kernel pair
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
18
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-08-23 10:14 EDT by Kamil Páral
Modified: 2012-09-27 02:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: livecd-tools-18.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 03:17:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot failure (91.99 KB, image/jpeg)
2012-08-23 10:14 EDT, Kamil Páral
no flags Details
syslinux menu (127.46 KB, image/jpeg)
2012-08-23 10:15 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-08-23 10:14:35 EDT
Created attachment 606607 [details]
boot failure

Description of problem:
Created bootable USB using this command:
$ sudo livecd-iso-to-disk --format --reset-mbr --efi /mnt/data/iso/Fedora-18-Alpha-TC3-x86_64-DVD.iso /dev/sdb

It fails to boot, because vmlinuz is not found (see boot-fail.jpg).

The problem is in incorrect paths (see syslinux.jpg).

The correct paths are /syslinux/{vmlinuz,initrd.img}. If I change them in the menu, it starts to boot.

Version-Release number of selected component (if applicable):
livecd-tools-17.14-1.fc17.x86_64

How reproducible:
always
Comment 1 Kamil Páral 2012-08-23 10:15:13 EDT
Created attachment 606608 [details]
syslinux menu
Comment 2 Kamil Páral 2012-08-23 10:19:31 EDT
We don't have an EFI release criterion. But we have this:
" The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods "
https://fedoraproject.org/wiki/Fedora_18_Alpha_Release_Criteria

I assume EFI falls into "system firmware types that are common". Now, only one way of creating USB sticks has to work for Alpha. But I don't know whether any other way other than livecd-iso-to-disk supports creating EFI-bootable images. Therefore I nominate for an Alpha blocker. If we discover that other ways (dd or liveusb-creator) also can create EFI-enable USB stick, we can drop the blocker status.
Comment 3 Brian Lane 2012-08-23 18:45:20 EDT
The problem here is that litd needs to be updated for grub2.
Comment 4 Adam Williamson 2012-08-23 20:46:51 EDT
'I assume EFI falls into "system firmware types that are common"'

Yes, that bit of the criterion was added specifically to cover UEFI: since F17 we consider UEFI boot 'supported' at Alpha stage. +1 blocker.

Our expectation is that dd'ed images should be EFI bootable - the images are created in such a way that this ought to be the case, and it worked for F17 - but I expect this is likely also broken with the general 'usb boot broken' bug.

So Brian, er, exactly how many bugs do we have here now? I know you said that 'litd-written USB stick doesn't boot (BIOS)' and 'dd-written USB stick doesn't boot (BIOS)' should be considered separate bugs even though at present they fail in exactly the same way, is this yet a third bug 'litd-written USB stick doesn't boot (EFI)'? Or is it really the same as 'litd-written USB stick doesn't boot (BIOS)'?
Comment 5 Adam Williamson 2012-08-27 12:18:00 EDT
Discussed at 2012-08-27 QA meeting, functioning as a blocker review meeting. Accepted as a blocker per criterion cited in comment #2.
Comment 6 Brian Lane 2012-08-27 12:49:49 EDT
This bug is different than the others related to stage2 and splitsep. So we have 4 things that need to happen:

1. dracut fix for splitsep
2. lorax add stage2=hd:LABEL=...
3. litd support for stage2
4. litd support for grub2
Comment 7 Adam Williamson 2012-08-29 13:14:21 EDT
bcl says this bug needs the splitsep fix for dracut, so marking it as depending on that bug.
Comment 8 Adam Williamson 2012-08-29 13:14:41 EDT
Crap, wrong one. Sorry.
Comment 9 Fedora Update System 2012-09-06 16:08:37 EDT
livecd-tools-18.9-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/livecd-tools-18.9-1.fc18
Comment 10 Adam Williamson 2012-09-06 17:18:34 EDT
Do we also need updates for livecd-tools for F16 and F17? Can they be made to DTRT for both 18 images and <18 images?
Comment 11 Adam Williamson 2012-09-06 17:37:55 EDT
TC6 written with livecd-iso-to-disk from livecd-tools 18.9-1, with --efi, does not manage to boot the installer. It gets to a correct-looking grub menu; trying to boot the default entry results in an error:

error: file `/images/pxeboot/vmlinuz' not found.
error: you need to load the kernel first.

after a few seconds it goes back to the grub menu, if you try again, same error.
Comment 12 Brian Lane 2012-09-06 19:22:49 EDT
(In reply to comment #10)
> Do we also need updates for livecd-tools for F16 and F17? Can they be made
> to DTRT for both 18 images and <18 images?

yes. I'll backport the litd changes, but not the grub2/shim changes in python-imgcreate
Comment 13 Fedora Update System 2012-09-06 20:45:11 EDT
livecd-tools-16.16-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/livecd-tools-16.16-1.fc16
Comment 14 Fedora Update System 2012-09-06 20:46:44 EDT
livecd-tools-17.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.15-1.fc17
Comment 15 Kamil Páral 2012-09-07 09:04:33 EDT
livecd-tools-17.15-1.fc17 fixed the problem for me
Comment 16 Kamil Páral 2012-09-11 14:54:56 EDT
Because this is fixed in F17 version of livecd-tools, I'm setting to VERIFIED. Even if F18 livecd-tools is still broken (can somebody check?), F16 and F17 are now more important for us.
Comment 17 Adam Williamson 2012-09-18 15:06:55 EDT
note that 18.10 was pushed stable so this is fixed wrt 18. 17.15 has been submitted for stable so it'll be fixed wrt 17 with the next stable push.
Comment 18 Fedora Update System 2012-09-18 23:11:29 EDT
livecd-tools-17.15-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-09-22 23:25:41 EDT
livecd-tools-16.16-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Kamil Páral 2012-09-24 03:17:34 EDT
All pushed stable, closing.

Note You need to log in before you can comment on or make changes to this bug.