Bug 851237 - [FEAT] Add gluster cli interface for setting a 'group' of options in one go.
[FEAT] Add gluster cli interface for setting a 'group' of options in one go.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
: 1006698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 10:41 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:34:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2012-08-23 10:41:42 EDT
Description of problem:

Gluster CLI doesn't have an interface that facilitates setting of multiple options in one go, which can be grouped by a purpose. ie., if the storage admin wants to set a group of options in order to favour certain work loads like volumes serving VM images, small files etc, she should remember them everytime such a volume is created and apply those options onto the volume.

One way to solve the above 'gap' is as follows,
#gluster volume set VOLNAME group virt

Here "group" is a special (reserved) key. "virt" would be the name of the file under /var/lib/glusterd/groups, which contains the options that need to be set on a volume. The file must be of the following format,

key1=value1
key2=value2
[...]

The admin has the flexibility of grouping her own options under a group name, like "virt" in the above example and applying it to volumes wherever applicable. She could also modify what options (and values) of a group, but should remember that the updated values don't take effect to the volumes that were 'set' with the group options prior to the update.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 krishnan parthasarathi 2012-10-01 12:48:13 EDT
Fixed by http://review.gluster.org/3831 on master.
Comment 2 Vijay Bellur 2012-12-11 19:42:26 EST
CHANGE: http://review.gluster.org/4232 (Added virt group file - template for 'group' set) merged in master by Anand Avati (avati@redhat.com)
Comment 3 Niels de Vos 2014-09-27 14:32:38 EDT
*** Bug 1006698 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.