Bug 851261 - Status and Power status not updated after "os-stop" action
Status and Power status not updated after "os-stop" action
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
1.0 (Essex)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Julie Pichon
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 11:23 EDT by Jaroslav Henner
Modified: 2016-04-26 11:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 10:17:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Henner 2012-08-23 11:23:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Puddle Essex 2012-08-10.3

How reproducible:
always

Steps to Reproduce:
1. Have a server
2. Stop it using:

echo '{"os-stop": null}' \
| curl -H 'accept: application/json' \
       -H 'Content-Type: application/json' \
       -H 'X-Auth-Token: e9de9e0863d3474b8b20d3078a7c35b7' \
       --data @- \
'http://nova-api.lithium:8774/v2/77ee297e46894491b6836119608b2b1c/servers/2d6c3405-c59e-4593-8736-56c0d033f611/action'

3. Observe status in dashboard
  
Actual results:
Status: Stopped, hourglass
Power State: Running, after some time it switches to No State

Expected results:
Stopped, no hourglass, SHUTOFF

Additional info:
Severity high because it causes long waiting for timeout in Tempest tests
Comment 2 Jaroslav Henner 2012-08-23 11:31:16 EDT
Note that the server really shuts down -- virsh list gets empty and it disappears from virt-manager, but the power status is not updated.
Comment 3 Alan Pevec 2012-11-05 11:42:20 EST
> 3. Observe status in dashboard
So is this a Dashboard issue, not Nova?
Comment 4 Alan Pevec 2012-12-17 05:22:54 EST
Please try with latest python-django-horizon-2012.2.1-2.el6ost
Comment 5 Julie Pichon 2013-01-14 10:17:15 EST
Using Folsom / python-django-horizon-2012.2.1-2.el6ost, if I run the curl command in the description, the instance status and power state in the dashboard immediately switch to "shutoff" and "shutdown".

Note You need to log in before you can comment on or make changes to this bug.