Bug 851278 - Realtek RTL-8139/8139C/8139C+ ethernet adapter stops working in kernel 3.5.x
Realtek RTL-8139/8139C/8139C+ ethernet adapter stops working in kernel 3.5.x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 12:20 EDT by Tom Pinkl
Modified: 2012-12-17 21:34 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 03:26:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug fix (1.10 KB, patch)
2012-11-14 16:20 EST, William J. Eaton
no flags Details | Diff

  None (edit)
Description Tom Pinkl 2012-08-23 12:20:57 EDT
Description of problem:

The Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 20) Ethernet adapter does not work under kernel 3.5.x.  It *does* work under kernel 3.4.4-5.

Version-Release number of selected component (if applicable):
See above.

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 William J. Eaton 2012-11-14 16:18:55 EST
This bug was observed under Fedora 17 i686 on an HP pavilion zt3010US laptop with revision 20 of some RTL-8139/C/C+ NIC on the motherboard.  Upon connecting to a network with a DHCP server, NetworkManager never gets an IP address, and no packets are transmitted from the laptop.  The NIC uses the 8139cp driver.  The 3.5
 and 3.6 kernels are affected, the 3.4 kernels work.  The system logs show nothing unusual until the point where the NIC fails to obtain a DHCP address.

The code in cp_init_hw() in the kernel 8139cp module was changed at 3.5, setting up the ring buffers before rather than after enabling transmit/receive.  This prevents the NIC from transmitting packets.

A patch is attached to fix the problem for the 3.6 kernels.  It should work on 3.5.x also.  The 3.7 kernels have not been tested.
Comment 2 William J. Eaton 2012-11-14 16:20:33 EST
Created attachment 645181 [details]
Bug fix

Realtek 8139cp driver patch
Comment 3 William J. Eaton 2012-11-26 14:12:29 EST
This bug appears to have been reported and fixed upstream at kernel.org.
https://bugzilla.kernel.org/show_bug.cgi?id=47271

The fix is already in the sacred source tree of the Holy One. :-)
Comment 4 Josh Boyer 2012-11-26 14:46:09 EST
Nice spot.  We'll get this in.
Comment 5 Josh Boyer 2012-11-26 14:49:09 EST
Patch applied.  Thanks for your efforts on this one William.
Comment 6 Josh Boyer 2012-11-26 17:15:36 EST
Actually, we have two different commits we were pointed to in net-next by David Woodhouse.  Would you please give this scratch build a try when it completes and let us know if the problem is resolved for you?

http://koji.fedoraproject.org/koji/taskinfo?taskID=4730596
Comment 7 William J. Eaton 2012-11-27 13:48:34 EST
This build resolves the problem.  Several boots and cable connect/disconnect cycles were done to confirm that the Ethernet port was working properly.
Comment 8 Josh Boyer 2012-11-27 13:59:11 EST
Excellent.  Thank you for letting us know.  I'll get these fixes in today.
Comment 9 Fedora Update System 2012-11-28 07:58:20 EST
kernel-3.6.8-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc16
Comment 10 Fedora Update System 2012-11-28 08:28:29 EST
kernel-3.6.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.8-2.fc17
Comment 11 Fedora Update System 2012-11-28 22:57:00 EST
Package kernel-3.6.8-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.8-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19337/kernel-3.6.8-2.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-12-01 03:26:16 EST
kernel-3.6.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-12-04 16:13:29 EST
kernel-3.6.9-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.9-4.fc18
Comment 14 Fedora Update System 2012-12-04 16:18:16 EST
kernel-3.6.9-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.9-2.fc16
Comment 15 Fedora Update System 2012-12-06 23:25:29 EST
kernel-3.6.9-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-12-11 15:18:11 EST
kernel-3.6.10-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.10-2.fc16
Comment 17 Fedora Update System 2012-12-17 21:34:12 EST
kernel-3.6.10-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.