Bug 851303 - rhn-migrate-classic-to-rhsm man page updates
rhn-migrate-classic-to-rhsm man page updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deon Ballard
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993 895654
  Show dependency treegraph
 
Reported: 2012-08-23 14:01 EDT by Matt Reid
Modified: 2013-02-21 03:55 EST (History)
4 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:55:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-08-23 14:01:05 EDT
Description of problem:
There are some updates we need to make to the man page of rhn-migrate-classic-to-rhsm to get it in line with our updated terminology. The suggestions below are based off of looking at version .3, last updated May 3, 2012.

Please let me know if you have any questions.

-----------------

Name
Migrates a system profile from Red Hat Network Classic Hosted to Certificate-based Red Hat Network Hosted
cert-based rhn -> Red Hat Subscription Management

Description
rhn-migrate-classic-to-rhsm migrates a system profile which is registered with Red Hat Network Classic to Certificate-based Red Hat Network. This is intended for hosted-to-hosted migrations, not for migrating from a Satellite. 
Cert-based RHN -> Red Hat Subscription Management

Background
Subscriptions are assigned to a system...
assigned -> attached

Subscriptions for an entire organization are tracked through a subscription service, either a local Satellite or hosted Red Hat Network. 
Could also be some other subscription management service, such as Cloudforms System Engine, or Subscription Asset Manager

When subscriptions are allocated to a system, it is noted in the subscription service.
allocated -> attached
subscription service -> subscription management service

For environments which use a hosted subscription service rather than a local Satellite system, systems were registered with Red Hat Network Classic. 
subscription service -> subscription management service

Red Hat Network Classic, however, has been replaced by Certificate-based Red Hat Network.
Cert-based RHN -> Red Hat Subscription Management

looks like DOC-45987 is broken at the moment, should probably be replaced with https://access.redhat.com/knowledge/articles/63269

Registering with a subscription service is exclusive. If a system is registered with Red Hat Network Classic, it cannot simultaneously be registered with Cert-based RHN.
subscription service -> subscription management service
Certificate-based Red Hat Network ->Red Hat Subscription Management

Options
-f, --force
Ignore channels not available on Cert-based RHN. -> Red Hat Subscription Management

Cert-based RHN -> Red Hat Subscription Management

Cert-based RHN -> RH Subscription Management

-c
Cert-based RHN -> RH Subscription Management

-n
Cert-based RHN -> RH Subscription Management
... subscribe the system to any entitlements. -> attach any subscriptions to the system.

Usage
subscription service -> subscription management service
Cert-based RHN -> RH Subscription Management

1. Cert-based RHN -> RH Subscription Management
6. Cert-based RHN -> RH Subscription Management
7. Open Subscription Manager to subscribe to the new entitlements. -> Open Subscription Manager to attach the new subscriptions.

By default, this opens the GUI to allow administrators to assign subscriptions manually...
assign subscriptions -> attach

Basic Migration
Simply running the ... and then open the Subscription Manager GUI so that administrators can assign subscriptions to the system. 
open -> opens
assign -> attach

Cert-based RHN -> RH Subscription Management

RHN classic -> RHN Classic

Cert-based RHN -> RH Subscription Management
Cert-based RHN -> RH Subscription Management

Unregister
Cert-based RHN -> RH Subscription Management
RHN classic -> RHN Classic
RHN classic -> RHN Classic

Files
Cert-based RHN -> RH Subscription Management
... or with subscribing the system to entitlements. -> attaching subscriptions to the system.

Bugs
may want to add a bit more direction on where/what to file bugs against in BZ, since this doesn't show as a component in RHEL
Comment 3 Adrian Likins 2012-11-09 15:01:37 EST
commit 5354a77b1d1cf85e98c880005b8e8a303e0a74eb
Author: elladeon <dlackey@redhat.com.com>
Date:   Fri Nov 9 13:54:56 2012 -0600

    bz851303: terminology updates and edits to rhn-migrate-classic-to-rhsm. adding version command, --serverurl and --bas
Comment 5 John Sefler 2013-01-03 11:58:56 EST
Testing Version....
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64
[root@jsefler-6 ~]# man -P cat rhn-migrate-classic-to-rhsm | tail -1
Version 0.6                    November 8, 2012 rhn-migrate-classic-to-rhsm(8)


(In reply to comment #0)
> Description of problem:
> There are some updates we need to make to the man page of
> rhn-migrate-classic-to-rhsm to get it in line with our updated terminology.
> The suggestions below are based off of looking at version .3, last updated
> May 3, 2012.
> 
> Please let me know if you have any questions.
> 
> -----------------
> 
> Name
> Migrates a system profile from Red Hat Network Classic Hosted to
> Certificate-based Red Hat Network Hosted
> cert-based rhn -> Red Hat Subscription Management

VERIFIED: actual updated by another bug to "Customer Portal Subscription Management (hosted) or Subscription Asset Manager (on-premise)"


> Description
> rhn-migrate-classic-to-rhsm migrates a system profile which is registered
> with Red Hat Network Classic to Certificate-based Red Hat Network. This is
> intended for hosted-to-hosted migrations, not for migrating from a
> Satellite. 
> Cert-based RHN -> Red Hat Subscription Management

VERIFIED: actual updated by another bug to "Customer Portal Subscription Management"


> Background
> Subscriptions are assigned to a system...
> assigned -> attached

VERIFIED


> Subscriptions for an entire organization are tracked through a subscription
> service, either a local Satellite or hosted Red Hat Network. 
> Could also be some other subscription management service, such as Cloudforms
> System Engine, or Subscription Asset Manager

VERIFIED: changed to "Subscriptions for an entire account are tracked through a subscription service."


> When subscriptions are allocated to a system, it is noted in the
> subscription service.
> allocated -> attached

FAILED: changed to "applied" in phrase: When subscriptions are applied to a system, that association is noted in the subscription service.


> subscription service -> subscription management service

FAILED: was not changed in phrase: When subscriptions are applied to a system, that association is noted in the subscription service.


> For environments which use a hosted subscription service rather than a local
> Satellite system, systems were registered with Red Hat Network Classic. 
> subscription service -> subscription management service

FAILED: searching through the man page, you will currently find 8 instances of "subscription service" for which a change to "subscription management service" is being requested


> Red Hat Network Classic, however, has been replaced by Certificate-based Red
> Hat Network.
> Cert-based RHN -> Red Hat Subscription Management

VERIFIED: has been re-worded to:   The differences between the two types of subscription services are described in  this Knowledgebase article:  <https://access.redhat.com/knowledge/articles/63269>


> looks like DOC-45987 is broken at the moment, should probably be replaced
> with https://access.redhat.com/knowledge/articles/63269

VERIFIED


> Registering with a subscription service is exclusive. If a system is
> registered with Red Hat Network Classic, it cannot simultaneously be
> registered with Cert-based RHN.
> subscription service -> subscription management service
> Certificate-based Red Hat Network ->Red Hat Subscription Management

VERIFIED: actual value changed by other bug to: Customer Portal Subscription Management


> Options
> -f, --force
> Ignore channels not available on Cert-based RHN. -> Red Hat Subscription
> Management

VERIFIED: actual value: Customer Portal Subscription Management (or Subscription Asset Manager)


> Cert-based RHN -> Red Hat Subscription Management

VERIFIED: actual value: Customer Portal Subscription Management


> Cert-based RHN -> RH Subscription Management
> 

VERIFIED: actual value: Customer Portal Subscription Management


> -c
> Cert-based RHN -> RH Subscription Management

VERIFIED: -c does not exist, but all occurances of Cert-based RHN have been changed to Customer Portal Subscription Management


> -n
> Cert-based RHN -> RH Subscription Management
> ... subscribe the system to any entitlements. -> attach any subscriptions to
> the system.

VERIFIED


> Usage
> subscription service -> subscription management service

FAILED

> Cert-based RHN -> RH Subscription Management

VERIFIED


> 1. Cert-based RHN -> RH Subscription Management

VERIFIED: actual value: Customer Portal Subscription Management


> 6. Cert-based RHN -> RH Subscription Management

VERIFIED: actual value: Customer Portal Subscription Management


> 7. Open Subscription Manager to subscribe to the new entitlements. -> Open
> Subscription Manager to attach the new subscriptions.

VERIFIED


> By default, this opens the GUI to allow administrators to assign
> subscriptions manually...
> assign subscriptions -> attach

VERIFIED


> Basic Migration
> Simply running the ... and then open the Subscription Manager GUI so that
> administrators can assign subscriptions to the system. 
> open -> opens
> assign -> attach

VERIFIED: this section has been re-written


> Cert-based RHN -> RH Subscription Management
> 
> RHN classic -> RHN Classic

FAILED: This string actually comes from the code which has been updated to "RHN Classic" by seperate bug.

> 
> Cert-based RHN -> RH Subscription Management
> Cert-based RHN -> RH Subscription Management
> 
> Unregister
> Cert-based RHN -> RH Subscription Management
> RHN classic -> RHN Classic
> RHN classic -> RHN Classic
> 
> Files
> Cert-based RHN -> RH Subscription Management
> ... or with subscribing the system to entitlements. -> attaching
> subscriptions to the system.

VERIFIED



> Bugs
> may want to add a bit more direction on where/what to file bugs against in
> BZ, since this doesn't show as a component in RHEL

VERIFIED



FAILED: The examples in the man page show a prompt for either "Username:" or "RHN Username:"  This should be..
       Red Hat account: jsmith@example.com
       Password:


Moving back to ASSIGNED
Comment 6 Deon Ballard 2013-01-07 11:14:52 EST
commit 7839778c462c527437a8ac64296a9ee34df554a3
Comment 8 John Sefler 2013-01-08 19:57:17 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64
[root@jsefler-6 ~]# man -P cat rhn-migrate-classic-to-rhsm | tail -1
Version 0.7                     January 7, 2013 rhn-migrate-classic-to-rhsm(8)


All of the issues raised in the comments above are fixed in this version of the rhn-migrate-classic-to-rhsm man page as included below:


[root@jsefler-6 ~]# man -P cat rhn-migrate-classic-to-rhsm
rhn-migrate-classic-to-rhsm(8)                  rhn-migrate-classic-to-rhsm(8)



NAME
       rhn-migrate-classic-to-rhsm  -  Migrates  a system profile from Red Hat
       Network Classic  Hosted  to  Customer  Portal  Subscription  Management
       (hosted) or Subscription Asset Manager (on-premise).


SYNOPSIS
       rhn-migrate-classic-to-rhsm  [--force  |  --gui  |  --no-auto  | --ser-
       vicelevel=SERVICE_LEVEL | --serverurl=URL | --help]


DESCRIPTION
       rhn-migrate-classic-to-rhsm migrates a system profile which  is  regis-
       tered with Red Hat Network Classic to Customer Portal Subscription Man-
       agement. This is intended for migrating from the host service, not  for
       migrating from a Satellite system.


       This  script  migrates configuration, from a channel-based subscription
       framework to a certificate-based subscription framework. While the rhn-
       migrate-classic-to-rhsm  script  performs  the migration operation, the
       data used to map the channels to the corresponding product certificates
       is defined in the subscription-manager-migration-data package. The sub-
       scription-manager-migration-data package must be installed  before  the
       rhn-migrate-classic-to-rhsm script can be run successfully.


BACKGROUND
       Access  to  support and updates for products is determined through sub-
       scriptions.  Subscriptions are attached to a system, which  means  that
       the system has the right to install and update a product with full sup-
       port. Subscriptions for an entire account are tracked  through  a  sub-
       scription management service.


       With the channel-based framework, a subscription management service was
       either an on-premise Satellite or hosted Red Hat Network Classic.  With
       the  new  certificate-based  subscriptions, the subscription management
       service is either Customer Portal Subscription Management or  Subscrip-
       tion  Asset Manager. The differences between the two types of subscrip-
       tion management services are described in this  Knowledgebase  article:
       <https://access.redhat.com/knowledge/articles/63269>


       The  system  registers  with  the  subscription  management service and
       receives an inventory ID number. When subscriptions are attached  to  a
       system,  that  association is noted in the subscription management ser-
       vice.


       Registering with a subscription management service is exclusive.  If  a
       system is registered with Red Hat Network Classic, it cannot simultane-
       ously be registered with Customer Portal Subscription  Management.  The
       rhn-migrate-classic-to-rhsm tool is provided specifically so that there
       is a way to transition from the deprecated Red Hat Network  Classic  to
       Customer  Portal  Subscription Management or an on-premise Subscription
       Asset Manager.


OPTIONS
       -h, --help
              Prints the specific help information for the given command.


       -f, --force
              Ignore channels not available through Customer Portal  Subscrip-
              tion Management (or Subscription Asset Manager). The channels in
              Red Hat Network Classic are mapped to the  product  certificates
              used  by  the  Customer Portal Subscription Management. However,
              not every channel has a certificate  mapping,  which  can  cause
              errors  during  migration.  Using this option skips any channels
              which are not mapped to Customer Portal Subscription Management.


       -g, --gui
              Opens  the  Subscription  Manager  UI so that administrators can
              manually select which  subscriptions  to  apply  to  the  system
              rather  than  automatically  applying best-matched subscriptions
              based on the existing channel subscriptions.


       -n, --no-auto
              Deletes the system from Red Hat Network Classic and registers it
              to  Customer Portal Subscription Management, but does not attach
              any subscriptions to the system.


       -s SERVICE_LEVEL, --servicelevel=SERVICE_LEVEL
              Sets a preferred service level for the system, such  as  premium
              or  standard.  This service level preference is then used as one
              of the criteria for autoattaching subscriptions to the system.


       --serverurl=URL
              Gives the URL of the subscription management service to which to
              register the system. This is used for environments which have an
              on-premise subscription management service such as  Subscription
              Asset  Manager.  If no URL is given, the migration tool uses the
              Customer Portal Subscription Management Service.


USAGE
       The migration process moves the system from the inventory in  one  sub-
       scription  management service (Red Hat Network Classic) to the new sub-
       scription management service (Customer Portal Subscription Management),
       and  then  re-applies  the subscriptions to the system. The script runs
       through these steps:


              1. Authenticate to both Red Hat  Network  Classic  and  Customer
              Portal Subscription Management to verify the account settings.


              2. Get a channel list for the system.


              3. Match each channel to a corresponding certificate map.


              4. Copy over the product certificates for the old channels.


              5. Unregister from Red Hat Network Classic.


              6.  Register  with  Customer  Portal Subscription Management and
              autoattach the best-matched subscriptions.  (Alternatively,  the
              --gui  option  can be used to launch the Subscription Manager UI
              to attach subscriptions manually.)


       After migration, the system facts maintained  by  Subscription  Manager
       display what script was used for migration and what the previous system
       ID was.
       [root@server ~]# subscription-manager facts --list | grep migr
       migration.classic_system_id: 09876
       migration.migrated_from: rhn_hosted_classic
       migration.migration_date: 2012-09-14T14:55:29.280519



   MIGRATION AND AUTOSUBSCRIBE
       The rhn-migrate-classic-to-rhsm  tool,  by  default,  autoattaches  the
       best-matching subscriptions to the system. This allows migrations to be
       automated.
       [root@server ~]# rhn-migrate-classic-to-rhsm
       Red Hat account: jsmith@example.com
       Password:

       Retrieving existing RHN Classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN Classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System ’server.example.com’ successfully registered to RHN.

       Attempting to auto-subscribe to appropriate subscriptions ...
       Installed Product Current Status:
       ProductName:            Red Hat Enterprise Linux Desktop
       Status:                 Subscribed

       Successfully subscribed.

       Please visit https://access.redhat.com/management/consumers/abcd1234 to view the details, and to make changes if necessary.


       The script prompts for a username and password to use to  register  the
       system;  this  same  account  is used to authenticate with both Red Hat
       Network Classic and Customer Portal Subscription Management.


       Optionally, the --servicelevel argument sets an SLA preference  to  use
       with  the system. The SLA associated with a subscription is then evalu-
       ated when determining what subscriptions to autoattach to  the  system,
       along  with  other  factors  like  installed products, existing channel
       assignments, and architecture.

       [root@server ~]# rhn-migrate-classic-to-rhsm --servicelevel=premium
       Red Hat account: jsmith@example.com
       Password:


   MIGRATION TO ON-PREMISE SERVICES
       The rhn-migrate-classic-to-rhsm tool migrates the  system  to  Customer
       Portal  Subscription Management (hosted) services by default. This uses
       the default configuration for Subscription Manager, which points to the
       subscription  management  services for the Customer Portal. For infras-
       tructures which have an on-premise subscription management service such
       as  Subscription  Asset  Manager,  this configuration can be changed so
       that the migration process registers the systems to the on-premise sub-
       scription  management  service  and  attaches the appropriate subscrip-
       tions.


       This is done by using the --serverurl option, which specifies  the  URL
       of  the on-premise service. In this case, the authorization credentials
       must also be given for the on-premise subscription  management  service
       account (which is independent of the RHN account).

       [root@server ~]# rhn-migrate-classic-to-rhsm --serverurl=sam.example.com
       Red Hat account: jsmith@example.com
       Password:


   MIGRATION AND MANUALLY SELECTING SUBSCRIPTIONS
       The  --no-auto  option  prevents  the autoattach step from running. The
       --gui option not only prevents autoattach from  running,  it  automati-
       cally  opens  the  Subscription  Manager GUI so that administrators can
       attach subscriptions to the system.


       As with the autoattach process, the script prompts for the RHN username
       and password for the user.

       [root@server ~]# rhn-migrate-classic-to-rhsm --gui
       Red Hat account: jsmith@example.com
       Password:

       Retrieving existing RHN Classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN Classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System server.example.com successfully registered to RHN.

       Launching the GUI tool to manually subscribe the system ...


FILES
       /etc/sysconfig/rhn/systemid
              The  digital  server  ID for this machine if the system has been
              registered with Red Hat Network Classic.   This  file  does  not
              exist otherwise.


       /etc/sysconfig/rhn/up2date
              The common configuration file used by RHN client programs.


       /var/log/rhsm/rhsm.log
              The Subscription Manager log file. This contains any errors reg-
              istering the system to Customer Portal  Subscription  Management
              or with attaching subscriptions to the system.


       subscription-manager-migration-data.rpm
              The package which contains the mappings for the migration script
              to migrate channels to the appropriate product certificates.


SEE ALSO
       install-num-migrate-to-rhsm(8), subscription-manager(8).



AUTHORS
       Deon Lackey  <dlackey@redhat.com>,  Paresh  Mutha  <pmutha@redhat.com>,
       Mark Huth <mhuth@redhat.com>, Tasos Papaioannou <tpapaioa@redhat.com>


BUGS
       This  script  is  part of the Red Hat Subscription Manager tool. Report
       bugs to <http://bugzilla.redhat.com>,  using  the  Red  Hat  Enterprise
       Linux product and the subscription-manager component.


COPYRIGHT
       Copyright © 2012 Red Hat, Inc.


       This is free software; see the source for copying conditions.  There is
       NO warranty; not even for MERCHANTABILITY or FITNESS FOR  A  PARTICULAR
       PURPOSE.



Version 0.7                     January 7, 2013 rhn-migrate-classic-to-rhsm(8)
[root@jsefler-6 ~]#
Comment 10 errata-xmlrpc 2013-02-21 03:55:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.