This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 851321 - Refresh/redraw tables after removing subscriptions
Refresh/redraw tables after removing subscriptions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 7.0
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-08-23 15:06 EDT by Matt Reid
Modified: 2014-06-17 20:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Two subscriptions (43.31 KB, image/png)
2012-08-23 15:06 EDT, Matt Reid
no flags Details
Eval Removed (37.63 KB, image/png)
2012-08-23 15:07 EDT, Matt Reid
no flags Details
After restarting sub man with the 1 sub (39.30 KB, image/png)
2012-08-23 15:07 EDT, Matt Reid
no flags Details
subs-man resizing subscriptions table (1.09 MB, image/png)
2013-10-15 13:52 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Matt Reid 2012-08-23 15:06:14 EDT
Description of problem:
When we add something new to tables, we make sure all the rows are properly sized, but when we remove something, we leave the table alone and just remove the entry.

This can result in awkwardly sized name columns with unnecessary horizontal scrolling when a table contains subscriptions with very different name lengths, and a user removes the subscription with the longest name. The subscription gets removed, but the table doesn't update its layout, so the name column ends up being much longer than it needs to be.

If our redraw is quick, it'd be nice to refresh the table layout when something is removed. The only way I've gotten it to update to the proper sizing is to close subscription manager and reopen it.

Reproduce:
1. Attach a long winded subscription (such as an eval) and a shorter one (like RH Employee)
2. Go to My Subscriptions Tab
3. Remove the eval subscription, name column doesn't refresh, and user has to scroll horizontally to see the rest of the sub info in the table
Comment 1 Matt Reid 2012-08-23 15:06:46 EDT
Created attachment 606690 [details]
Two subscriptions
Comment 2 Matt Reid 2012-08-23 15:07:10 EDT
Created attachment 606691 [details]
Eval Removed
Comment 3 Matt Reid 2012-08-23 15:07:48 EDT
Created attachment 606692 [details]
After restarting sub man with the 1 sub
Comment 5 Carter Kozak 2013-09-26 10:34:40 EDT
This appears to have been fixed, we've made a lot of changes to this area since the bug was opened.
Comment 6 Matt Reid 2013-09-26 10:36:40 EDT
I think Cory cleaned this up, but I'm not positive.
Comment 8 Sharath Dwaral 2013-10-15 13:52:07 EDT
Created attachment 812639 [details]
subs-man resizing subscriptions table

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.3-1.el7
python-rhsm: 1.10.3-1.el7

The following scenarios are shown in the attachment (left to right)

1) My Subscriptions tab have two subscriptions one with a long name and other with a short name. In this scenario the table re-sizes itself and a horizontal scroll appears

2) When the subscription with a longer name is removed, the table resizes itself to fit the subscription with a shorter name and the horizontal scroll disappears

3) On re-adding a subscription with a longer the table re-sizes itself again and a horizontal scroll appears

VERIFIED
Comment 9 Ludek Smid 2014-06-13 05:26:38 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.