Bug 851325 - Move tooltip icon on System Reg Dialog more to the left
Move tooltip icon on System Reg Dialog more to the left
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: beta
: 7.0
Assigned To: John Sefler
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-08-23 15:41 EDT by Matt Reid
Modified: 2014-06-17 20:21 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:20:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Firstboot example (90.43 KB, image/png)
2012-08-23 15:47 EDT, Matt Reid
no flags Details
Dialog example (30.43 KB, image/png)
2012-08-23 15:48 EDT, Matt Reid
no flags Details
Updated screenshot, includes Activation Key work (111.94 KB, image/png)
2012-12-04 17:40 EST, Matt Reid
no flags Details
New Firstboot example (121.13 KB, image/png)
2013-10-22 16:48 EDT, Matt Reid
no flags Details
"I will use an Activation Key" checkbox has moved to the right. Is this what we want? (27.68 KB, image/png)
2014-02-04 11:57 EST, John Sefler
no flags Details
Tool tip on GUI and Firstboot (211.46 KB, image/png)
2014-02-04 12:55 EST, Sharath Dwaral
no flags Details
sub-man-gui-register-851325 with https://github.com/candlepin/subscription-manager/pull/907 (27.26 KB, image/png)
2014-02-12 12:23 EST, Adrian Likins
no flags Details
final screenshot of System Registration in subscription-manager-gui and subscription-manager-firstboot (775.47 KB, image/png)
2014-02-20 10:23 EST, John Sefler
no flags Details

  None (edit)
Description Matt Reid 2012-08-23 15:41:53 EDT
Description of problem:
It would be nice if we shifted the tooltip icon on the System Registration screen more to the left, to get it closer to the text it provides information about. This would also pull it off the very edge of the screen in firstboot (although it may not run off the edge when firstboot runs fullscreen). The dialog has a fixed width, but when it is run as part of firstboot at higher resolutions, it ends up being even farther away from the text.

Is there a way to fix it closer to the text, so that it would be unaffected by the screen width changing?
Comment 2 Matt Reid 2012-08-23 15:47:52 EDT
Created attachment 606694 [details]
Firstboot example
Comment 3 Matt Reid 2012-08-23 15:48:29 EDT
Created attachment 606695 [details]
Dialog example
Comment 4 Matt Reid 2012-12-04 17:40:25 EST
Created attachment 657786 [details]
Updated screenshot, includes Activation Key work

We should try to ensure that both tooltip icons are aligned at the very least.

If we're able to do more, it would be nice to get those icons closer to the text that they're associated with, moving them in near the right hand edge of the text field seems like a good point of reference. The Default button could also stand to be closer to the field.
Comment 5 Matt Reid 2013-10-22 16:48:12 EDT
Created attachment 815182 [details]
New Firstboot example

Adding Sharath's image of new firstboot at a large screen size, I've shown where we could move the tooltip icons and button, and added a few comments in red and green. Red comments call attention to what needs to move, and green says what we should try to change.

It seems like those elements need a different anchor point, as the screen size increases, they drift farther and farther away from the rest of the elements they're related to.
Comment 6 Devan Goodwin 2014-01-21 14:25:13 EST
Ok this is a bit confusing but here's what I did:

- Per https://bugzilla.redhat.com/show_bug.cgi?id=873967, I moved the tooltips closer to the fields they are relevant for, rather than aligning them with the "Default" button. This was requested but also seems more logical to me as these don't really have anything to do with the Default button.

- The default button should now anchor right beside the server textbox.

- Items 1 and 2 are actual firstboot considerations, they are not addressed as I don't think we have control over that left panel of firstboot screen titles. 

- For 3, I have not addressed this, please re-open if this is significant. Personally, because this code is shared with registration GUI, I don't think it's worth adjusting as that will have unintended consequences there, and I genuinely don't think we should fork the glade data for the two situations unless we have a very good reason to do so. IMO the better approach is to just let the info aggregate at the top of the screen.
Comment 7 Devan Goodwin 2014-01-29 08:33:31 EST
Changes as described in comment #6 are in subscription-manager.git commit 0c7a2488621d4400787e352d690a90d4919d9830.

Will appear in: subscription-manager-1.10.12-1
Comment 9 John Sefler 2014-02-04 11:10:26 EST
Tool tip relocation to the left was verified here:
  https://bugzilla.redhat.com/show_bug.cgi?id=873967#c5
  https://bugzilla.redhat.com/show_bug.cgi?id=873967#c6
Comment 10 John Sefler 2014-02-04 11:23:41 EST
VERIFIED: The Default button is anchored to the right and the serverurl field stretches to the right as shown here:
  https://bugzilla.redhat.com/attachment.cgi?id=859219
  https://bugzilla.redhat.com/attachment.cgi?id=859220
Comment 11 John Sefler 2014-02-04 11:57:49 EST
Created attachment 859253 [details]
"I will use an Activation Key" checkbox has moved to the right.  Is this what we want?

Since this bug is all about widget layout, dgoodwin's changes introduced a relocation of the activation key checkbox that I don't think was intentional. Originally the checkbox was immediately below and left aligned to the left edge of the serverurl text field.  It now appears centered to the dialog.  Do we prefer the new location or want the original location restored?
Comment 12 Matt Reid 2014-02-04 12:08:15 EST
I'd prefer the original way to keep it in-line with the left edge of the field, rather than indented.
Comment 13 Sharath Dwaral 2014-02-04 12:55:48 EST
Created attachment 859271 [details]
Tool tip on GUI and Firstboot

Version 

# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.2-1
subscription-manager: 1.10.13-1.el7
python-rhsm: 1.10.12-1.el7

Please see attachment..

1. As per comment 12 Activation key should be anchored tot he left
2. I see the tool tip on GUI aligned to the right and no to the text as shown in comment 11

QE_FAILED
Comment 15 Adrian Likins 2014-02-12 12:23:08 EST
Created attachment 862459 [details]
sub-man-gui-register-851325 with https://github.com/candlepin/subscription-manager/pull/907

With https://github.com/candlepin/subscription-manager/pull/907

(firstboot in rhel7 doesn't seem to like screenshots, but the dialog
looked the same).
Comment 16 Adrian Likins 2014-02-14 11:27:06 EST
commit 4aae51b87afd64d6fad4e73fbea1c5c6391e6fb0
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Feb 12 12:18:49 2014 -0500

    851325: Tweak activation key checkbox to left
Comment 17 John Sefler 2014-02-20 10:23:35 EST
Created attachment 865569 [details]
final screenshot of System Registration in subscription-manager-gui and subscription-manager-firstboot

Verified Version...
[root@jsefler-7 ~]# rpm -q subscription-manager-gui subscription-manager-firstboot
subscription-manager-gui-1.10.14-2.el7.x86_64
subscription-manager-firstboot-1.10.14-2.el7.x86_64
Comment 18 Ludek Smid 2014-06-13 08:20:35 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.