This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 851326 - Building boot.iso with lorax 18.14-1 crashes with efi errors
Building boot.iso with lorax 18.14-1 crashes with efi errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 15:43 EDT by Tim Flink
Modified: 2012-08-28 04:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: lorax-18.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-28 04:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to correct name of grub-cd.efi in lorax templates (1.11 KB, patch)
2012-08-23 15:43 EDT, Tim Flink
no flags Details | Diff

  None (edit)
Description Tim Flink 2012-08-23 15:43:16 EDT
Created attachment 606693 [details]
patch to correct name of grub-cd.efi in lorax templates

When I try to build a boot.iso with lorax-18.14-1 using:
 - kernel-3.6.0-0.rc2.git2.1.fc18
 - 1:grub2-2.00-5.fc18

I get the following traceback during the build process:

running x86.tmpl
template command error in x86.tmpl:
  install boot/efi/EFI/fedora/grub-cd.efi EFI/BOOT/grubx64.efi
  IOError: nothing matching /work/Fedora/x86_64/installroot/boot/efi/EFI/fedora/grub-cd.efi in /
Traceback (most recent call last):
  File "/usr/bin/pungi", line 256, in <module>
    main()
  File "/usr/bin/pungi", line 146, in main
    mypungi.doBuildinstall()
  File "/usr/lib/python2.7/site-packages/pypungi/__init__.py", line 909, in doBuildinstall
    workdir=workdir, outputdir=outputdir)
  File "/usr/lib/python2.7/site-packages/pylorax/__init__.py", line 286, in run
    treebuilder.build()
  File "/usr/lib/python2.7/site-packages/pylorax/treebuilder.py", line 216, in build
    self._runner.run(templatefile, kernels=self.kernels)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 176, in run
    self._run(commands)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 195, in _run
    f(*args)
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 228, in install
    for src in rglob(self._in(srcglob), fatal=True):
  File "/usr/lib/python2.7/site-packages/pylorax/ltmpl.py", line 95, in rglob
    raise IOError, "nothing matching %s in %s" % (pathname, root)
IOError: nothing matching /work/Fedora/x86_64/installroot/boot/efi/EFI/fedora/grub-cd.efi in /
ERROR: Command failed. See logs for output.

It turns out that grub-cd.efi has been renamed to gcdx64.efi and causing the commands in the template to fail.

I was able to patch lorax to make it work with the new kernel/grub and it has been working well so far. The patch is attached to this bug
Comment 1 Fedora Update System 2012-08-23 18:19:35 EDT
lorax-18.15-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.15-1.fc18
Comment 2 Fedora Update System 2012-08-23 21:24:11 EDT
Package lorax-18.15-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.15-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12621/lorax-18.15-1.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-08-28 04:04:52 EDT
lorax-18.15-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.