Bug 851411 - Error message is unclear when attempting to restore a domain from a non-existent file
Error message is unclear when attempting to restore a domain from a non-exist...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
: Upstream
: 1008533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 02:37 EDT by yanbing du
Modified: 2016-04-26 10:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-36.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 955500 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:14:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yanbing du 2012-08-24 02:37:47 EDT
Description of problem:
need clear error message when restore domain from the non-exist file

Version-Release number of selected component (if applicable):
libvirt-0.10.0-0rc1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Restore a domain from the non-exist file
# ls /tmp/test
ls: cannot access /tmp/test: No such file or directory
# virsh restore /tmp/test
error: Failed to restore domain from /tmp/test
error: Failed to create file '/tmp/test': Operation not permitted
2.
3.
  
Actual results:
error: Failed to create file '/tmp/test': Operation not permitted

Expected results:
The error message should be like: 
cannot access /tmp/test: No such file or directory

Additional info:
Comment 5 Laine Stump 2013-05-10 13:13:23 EDT
The error message in question has been fixed in the following upstream commit, which will be in libvirt-1.0.5 and has also been pushed to the v1.0.5-maint branch:

commit a2c1bedbd8fa977dc733266e88a1b57e28b50dd3
Author: Laine Stump <laine@laine.org>
Date:   Wed May 8 15:02:14 2013 -0400

    util: fix virFileOpenAs return value and resulting error logs
Comment 8 Jiri Denemark 2014-04-02 03:03:12 EDT
*** Bug 1008533 has been marked as a duplicate of this bug. ***
Comment 12 yangyang 2014-05-20 00:01:57 EDT
Verified this bug on libvirt-0.10.2-36.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.426.el6.x86_64
libvirt-0.10.2-36.el6.x86_64

Steps:
1. restore the guest from the non-exist file
# virsh restore /tmp/test
error: Failed to restore domain from /tmp/test
error: Failed to open file '/tmp/test': No such file or directory

2. save the guest to the non-exist file
# virsh save qcow3 /tmp/test/qcow3.save
error: Failed to save domain qcow3 to /tmp/test/qcow3.save
error: Failed to create file '/tmp/test/qcow3.save': No such file or directory

3. save the guest to the right file and the guest can be restored successfully
# virsh save qcow3 /tmp/qcow3.save
Domain qcow3 saved to /tmp/qcow3.save

# virsh restore /tmp/qcow3.save 
Domain restored from /tmp/qcow3.save

Since the reported error messages are clear, so I'd like to change the status to verified.
Comment 14 errata-xmlrpc 2014-10-14 00:14:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1374.html

Note You need to log in before you can comment on or make changes to this bug.