Bug 851454 - /distribution/kernelinstall installs non-PAE kernel on machine with >4G RAM
/distribution/kernelinstall installs non-PAE kernel on machine with >4G RAM
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
0.9
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 04:43 EDT by Guangze Bai
Modified: 2015-02-08 16:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 01:31:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guangze Bai 2012-08-24 04:43:42 EDT
Description of problem:

This is found from https://beaker.engineering.redhat.com/recipes/605021
<task name="/distribution/kernelinstall" role="STANDALONE">
    <params>
	<param name="KERNELARGNAME" value="kernel"/>
	<param name="KERNELARGVERSION" value="2.6.18-338.el5"/>
	<param name="KERNELARGVARIANT" value="up"/>
    </params>
</task>

IIRC, "up" can determine PAE or not automatically. This recipe initially installed a PAE kernel since the box has more than 4G RAM, but kernelinstall testcase installed a non-PAE kernel.

Version-Release number of selected component (if applicable):



Expected results:
Determine accordingly:
<4G, install non-PAE kernel
>4G, install PAE kernel

Additional info:
Comment 1 Guangze Bai 2012-09-07 01:31:27 EDT
oh, 'up' is supposed to mean non-PAE kernel while 'PAE' is PAE kernel. I don't know much about the history. Sorry for the noise.

Close NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.