Bug 851477 - cannot build jbossas/jbosseap app since local mirror site for maven is down
cannot build jbossas/jbosseap app since local mirror site for maven is down
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 05:38 EDT by Meng Bo
Modified: 2015-05-14 18:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-08-24 05:38:22 EDT
Description of problem:
Cannot download packages from local maven mirror “http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/”, so build for jbossas and jbosseap failed.

Version-Release number of selected component (if applicable):
http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/

How reproducible:
always

Steps to Reproduce:
1.Create jbossas/jbosseap app
2.Do some change and push build to trigger the maven build on server side
3.
  
Actual results:
Build failed due to cannot donwload packages from local mirror site 

Expected results:
Packages on local mirror site can be accessed.

Additional info:
remote: Found pom.xml... attempting to build with 'mvn -e clean package -Popenshift -DskipTests'
remote: Apache Maven 3.0.3 (r1075437; 2011-06-20 13:22:37-0400)
remote: Maven home: /etc/alternatives/maven-3.0
remote: Java version: 1.7.0_05-icedtea, vendor: Oracle Corporation
remote: Java home: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.5.x86_64/jre
remote: Default locale: en_US, platform encoding: UTF-8
remote: OS name: "linux", version: "2.6.32-279.5.1.el6.x86_64", arch: "amd64", family: "unix"
remote: [INFO] Scanning for projects...
remote: [INFO]                                                                         
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Building jbas1s 1.0
remote: [INFO] ------------------------------------------------------------------------
remote: Downloading: http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-clean-plugin/2.4.1/maven-clean-plugin-2.4.1.pom
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] BUILD FAILURE
remote: [INFO] ------------------------------------------------------------------------
remote: [INFO] Total time: 1:01.062s
remote: [INFO] Finished at: Fri Aug 24 05:33:05 EDT 2012
remote: [INFO] Final Memory: 4M/92M
remote: [INFO] ------------------------------------------------------------------------
remote: [ERROR] Plugin org.apache.maven.plugins:maven-clean-plugin:2.4.1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-clean-plugin:jar:2.4.1: Could not transfer artifact org.apache.maven.plugins:maven-clean-plugin:pom:2.4.1 from/to nexus (http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public): Error transferring file: Server returned HTTP response code: 502 for URL: http://mirror1.stg.rhcloud.com:80/nexus/content/groups/public/org/apache/maven/plugins/maven-clean-plugin/2.4.1/maven-clean-plugin-2.4.1.pom -> [Help 1]
remote: [ERROR] 
remote: [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
remote: [ERROR] Re-run Maven using the -X switch to enable full debug logging.
remote: [ERROR] 
remote: [ERROR] For more information about the errors and possible solutions, please read the following articles:
remote: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: Application will not be stopped during gear sync to to presence of hot_deploy marker
remote: Application will not be restarted during gear sync due to presence of hot_deploy marker
remote: SSH_CMD: ssh be39aa1f033f4b429125a9ef9afbcf2e@10.196.39.192
remote: ++ date
remote: + echo 'Syncing to gear: be39aa1f033f4b429125a9ef9afbcf2e@10.196.39.192:be39aa1f03 @ ' Fri Aug 24 05:33:09 EDT 2012
remote: Syncing to gear: be39aa1f033f4b429125a9ef9afbcf2e@10.196.39.192:be39aa1f03 @  Fri Aug 24 05:33:09 EDT 2012
remote: + for subd in '"${OPENSHIFT_SYNC_GEARS_DIRS[@]}"'
remote: + '[' -d /var/lib/stickshift/4b076ba3d14b470f8230e122b98be2a9/jbas1s//repo ']'
remote: + rsync -v --delete-after -az /var/lib/stickshift/4b076ba3d14b470f8230e122b98be2a9/jbas1s//repo/ be39aa1f033f4b429125a9ef9afbcf2e@10.196.39.192:be39aa1f03/repo/
remote: Warning: Identity file /var/lib/stickshift/4b076ba3d14b470f8230e122b98be2a9//haproxy-1.4/.ssh/haproxy_id_rsa not accessible: Permission denied.
remote: rsync: connection unexpectedly closed (0 bytes received so far) [sender]
remote: rsync error: error in rsync protocol data stream (code 12) at io.c(600) [sender=3.0.6]
remote: Exit code: 1
Comment 1 Yujie Zhang 2012-08-24 07:23:27 EDT
This issue also caused that the application of Spring Framework on JBoss EAP6 and Kitchensink Example can not be accessible on website.
Comment 2 Troy Dawson 2012-08-24 10:08:23 EDT
Nexus, which hosts the maven repository, was down on mirror1.  It has been restarted and is working again.
Comment 3 Adam Miller 2012-08-24 12:41:02 EDT
I was able to create a jbossas-7 application in STG. This issue should be resolved with Troy's fix of nexus, placing this ON_QA. Please verify that this is in fact NOTABUG.

Thanks,
-AdamM
Comment 4 Meng Bo 2012-08-26 22:22:11 EDT
Checked on latest stage, jbossas can download packages from local mirror.

Note You need to log in before you can comment on or make changes to this bug.