Bug 851519 - error message says "Date" when user attempts to manage channel for which he do not have permissions
error message says "Date" when user attempts to manage channel for which he d...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-08-24 08:38 EDT by Jan Hutař
Modified: 2014-10-06 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:57:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the error message saying "Date" (36.77 KB, image/png)
2012-08-24 08:49 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2012-08-24 08:38:51 EDT
Description of problem:
When you create user, give him right to manage child channel and attempt (as that user) to manage parent of that child, you get expected "Permission Error." page, but additional error message there says "Date", which is completely irrelevant.


Version-Release number of selected component (if applicable):
spacewalk-java-1.2.39-126.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Ensure you have at least 2 channels: parent and its child
2. Create user and grant him right to manage the child channel
   Users -> <your_new_user> -> Channel Permissions -> Management
     here select the child channel, do *not* select parent channel
3. Log-in as that new user and notice parent channel is linked as well, so
   it looks like you are able to manage it as well:
   Channels -> Manage Software Channels -> <parent_channel>
4. Attempt to manage the parent channel


Actual results:
Permission error page with error message saying "Date"


Expected results:
Permission error page
Comment 2 Jan Hutař 2012-08-24 08:49:32 EDT
Created attachment 606856 [details]
Screenshot of the error message saying "Date"
Comment 3 Tomas Lestach 2012-08-29 10:56:37 EDT
Valid bug. Strange we didn't hit it earier ...

spacewalk.git: d2635be3204f12e5f08ba6ea10545dd4e45ab79a
Comment 6 Clifford Perry 2013-10-01 17:57:06 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.