Bug 85163 - Square boxes in config tool v2 on linux run tests output
Summary: Square boxes in config tool v2 on linux run tests output
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: ConfigTool   
(Show other bugs)
Version: 2.0 beta 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John Dallaway
QA Contact: John Dallaway
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 03:15 UTC by Jonathan Larmour
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-25 10:16:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Larmour 2003-02-26 03:15:33 UTC
Description of problem:

When doing "Run tests" in the config tool v2 on linux, each line ends with a
square box. I guess this is some sort of carriage return character hangover from
windows, which is then displayed as a box in the font that wxgtk happens to use.

Comment 1 John Dallaway 2003-03-25 10:16:05 UTC
The CR characters appear to originate from gdb itself. I have worked around 
this issue by stripping CRs for non-Windows hosts in 
ecRunTestsDialog::TestOutputCallback(). 


Note You need to log in before you can comment on or make changes to this bug.