Bug 851632 - TypeError: object of type 'NoneType' has no len()
TypeError: object of type 'NoneType' has no len()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:0c9bac218109a5743952e8e3edf...
:
Depends On: 851628
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-08-24 10:24 EDT by Martin Banas
Modified: 2012-09-05 20:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 851628
Environment:
Last Closed: 2012-09-05 20:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Banas 2012-08-24 10:24:31 EDT
+++ This bug was initially created as a clone of Bug #851628 +++

Version-Release number of selected component:
anaconda-18.7

Additional info:
libreport version: 2.0.12
cmdline:        repo=http://nap/os/ ks=http://nap/ks
kernel:         3.5.0-0.24.el7.x86_64

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:20 EDT ---

Created attachment 606874 [details]
File: program.log

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:22 EDT ---

Created attachment 606875 [details]
File: environ

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:29 EDT ---

Created attachment 606876 [details]
File: type

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:32 EDT ---

Created attachment 606877 [details]
File: hashmarkername

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:34 EDT ---

Created attachment 606878 [details]
File: storage.log

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:38 EDT ---

Created attachment 606879 [details]
File: anaconda.log

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:39 EDT ---

Created attachment 606880 [details]
File: syslog

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:46 EDT ---

Created attachment 606881 [details]
File: product

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:49 EDT ---

Created attachment 606882 [details]
File: ks.cfg

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:51 EDT ---

Created attachment 606883 [details]
File: version

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:55 EDT ---

Created attachment 606884 [details]
File: release

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:57 EDT ---

Created attachment 606885 [details]
File: anaconda-tb

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:20:59 EDT ---

Created attachment 606886 [details]
File: ifcfg.log

--- Additional comment from mbanas@redhat.com on 2012-08-24 10:21:01 EDT ---

Created attachment 606887 [details]
File: description
Comment 1 Martin Banas 2012-08-24 10:25:22 EDT
This happens during kickstart installation, using graphical mode. Right now it's blocking kickstart installation, which means also automated testing.
Comment 2 Jaroslav Reznik 2012-08-24 10:49:07 EDT
Proposing as Beta blocker: "The installer must be able to use all kickstart delivery methods".
Comment 3 Brian Lane 2012-08-27 17:35:49 EDT
Vratislav,

The problem is that in LanguageMixIn._selectLanguage it is too strict about its language mapping. The store has en_US but it is looking for en_US.UTF-8 from the kickstart (or default).

Using expandLangs() from localization should fix it. Maybe like this:

while itr and store[itr][2] not in expandLangs(language):
Comment 4 Vratislav Podzimek 2012-08-28 10:17:51 EDT
(In reply to comment #3)
> Vratislav,
> 
> The problem is that in LanguageMixIn._selectLanguage it is too strict about
> its language mapping. The store has en_US but it is looking for en_US.UTF-8
> from the kickstart (or default).
> 
> Using expandLangs() from localization should fix it. Maybe like this:
> 
> while itr and store[itr][2] not in expandLangs(language):
That resolves the issue, thanks. Patch posted to anaconda-patches list for a review.
Comment 5 Fedora Update System 2012-09-01 01:11:58 EDT
anaconda-18.6.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.5-1.fc18
Comment 6 Fedora Update System 2012-09-01 12:56:38 EDT
Package anaconda-18.6.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13105/anaconda-18.6.5-1.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-05 20:53:35 EDT
anaconda-18.6.5-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.