Bug 851649 - Unable to disable or adjust settings for touch pad on DELL PRECISION laptop.
Unable to disable or adjust settings for touch pad on DELL PRECISION laptop.
Status: CLOSED DUPLICATE of bug 812111
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 11:23 EDT by Hal Ebi
Modified: 2013-02-12 13:37 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 13:37:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Ebi 2012-08-24 11:23:33 EDT
Description of problem:
I have a DELL Precision laptop with touchpad and track-point integrated pointing devices. Both devices are working on 3.5.2-1.fc17.x86_64 but I cannot adjust setting using "System Settings" for the touchpad, neither can I disable it. All areas of the three tabs (General, Scrolling, Tapping) are greyed out and under "General" the "Information" box says: "Touchpad Name: Device not found".

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics.x86_64 v. 1.6.2
kcm_touchpad.x86_64 v. 0.3.1

How reproducible:

Try modify setting through: "Application Launcher" -> "Settings" -> "System settings" -> "Input devices" -> "Touch Pad"

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Hutterer 2013-01-29 01:59:37 EST
what's the output of xinput list?
Comment 2 Hal Ebi 2013-01-30 08:54:05 EST
xinput output:

⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                        id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_E4HD             id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=14   [slave  keyboard (3)]
Comment 3 Peter Hutterer 2013-01-30 23:48:32 EST
Touchpad recognised as PS/2 generic mouse is a sign that the kernel does not set the touchpad into raw mode (usually because it isn't supported yet by the kernel). reassigning.
Comment 4 Josh Boyer 2013-02-11 12:54:36 EST
This is probably a duplicate of another bug we have open for lacking Dell touchpad support.  What model number is your laptop?
Comment 5 Hal Ebi 2013-02-12 06:58:59 EST
The laptop is a Dell Precision M4700.
Comment 6 Josh Boyer 2013-02-12 13:37:02 EST

*** This bug has been marked as a duplicate of bug 812111 ***

Note You need to log in before you can comment on or make changes to this bug.