Bug 85165 - Evolution freezes after a period of time of being open and not used
Evolution freezes after a period of time of being open and not used
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-25 22:33 EST by Eugenia Loli-Queru
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-20 18:08:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2003-02-25 22:33:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
User uses evolution to check email, sent out one email, left the machine running
(running random screensavers as they come with Phoebe3) and comes back 2-3 hours
later. The other two apps I had open at the time was Galeon and BlueFish 0.9.
Now the Evolution windows of menu/toolbar and left side panel are frozen and
their views are not updating anymore. Interestingly enough, the email list and
the email view panes are still working!
Screenshot here:
http://www.eugenia.co.uk/images/evolution.png

Another interesting thing was that when trying to manually press the "close"
button in the window manager, Evolution wouldn't close. This is normal when the
app is frozen,  but I know  that if you keep pressing Close, Metacity will
pop-up a dialog asking you to kill the app. In this case, Metacity won't show
any dialogs.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. See above.
2.
3.
    

Actual Results:  Evolution's left summary pane, menu and toolbar views are
frozen and they are not updating anymore, while the email list and email view
windows are still fully operational.

Expected Results:  To not freeze.

Additional info:

1600x1200x24bit color, 768 MB RAM, AthlonXP 1600+, 512 MB swap, screensavers ran
are the default ones that come with Phoebe3. Some of them are OpenGL ssavers,
and my card is not hardware OpenGL compatible, so they ran in software mode.
Comment 1 Jeremy Katz 2003-02-25 22:40:42 EST
I run evolution for days at a time on most of my machines and havne't seen this.
 Did you have any errors from evolution in ~/.xsession-errors?  If you look at
the processes running, are there any in a state other than sleeping?
Comment 2 Eugenia Loli-Queru 2003-02-25 22:57:58 EST
>Did you have any errors from evolution in ~/.xsession-errors?

I don't have this file at all. :o

> If you look at the processes running, are there any in a state other than
sleeping?

Sorry, I rebooted the machine after the evolution freeze. However, before I did
that, I tried to reload Evolution, and it wouldn't reload at all. Then, I tried
to load it via the terminal, and got this:

evolution-shell-WARNING **: CORBA exception
IDL:GNOME/Evolution/Shell/NotReady:1.0 when requesting URI -- evolution:/summary

Then, I tried to reboot, and found that the whole Gnome froze after I told the
dialog box to reboot. It seems that the OS has come to a state that _some_ apps
would freeze (not just Evolution). I killed X, and rebooted via the command line
and now I am back up, and Evolution loads fine.

I might be wrong, but I think that one of the screensavers might brought the
machine in this state, because at some point, a few minutes after an OpenGL
ssaver started (one of the random ones), it gave me an xscreensaver error. I
moved the mouse, gone out of the ssaver mode,  and then I went away and when I
came back (in the meantime the screensaver mode was back up and it was working
fine) Evolution was frozen.
Comment 3 Warren Togami 2003-03-03 16:22:32 EST
eloli and katzj, are you running Evolution with IMAP or local folders?

I have seen this bug in various versions of Evolution after 1.0.8 when using
very large IMAP folders.  Reliability when using my IMAP folders has been so
poor that I've switched to mozilla mail until it is fixed.  1.0.8 was stable in
this regard.
Comment 4 Dave Malcolm 2004-05-19 14:21:28 EDT
Is this bug still occurring with more recent versions of Evolution
(1.4.* and 1.5.*)?
Comment 5 Eugenia Loli-Queru 2004-05-19 15:48:38 EDT
Probably not, I haven't used it for a while though. I guess you can 
close the bug...
Comment 6 Dave Malcolm 2004-09-20 18:08:53 EDT
Without any more info (e.g. on whether large IMAP accounts were
involved) it's hard to do anything more with this bug.

Closing as WONTFIX; hopefully evolution-2.0.0 will work better for you.

Note You need to log in before you can comment on or make changes to this bug.