Bug 851688 - initscripts missing requires on hostname
initscripts missing requires on hostname
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 13:28 EDT by John Florian
Modified: 2014-03-16 23:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-28 08:54:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Florian 2012-08-24 13:28:57 EDT
Description of problem:

initscripts has calls to /bin/hostname in at least ifup-wireless and network-functions, but hostname is not spec'd as a required package by initscripts.


Version-Release number of selected component (if applicable):

initscripts-9.40-1.fc18.i686, but a quick check on Fedora 16 and 17 shows they're also affected.


Additional info:

According to #784363 and #784368, this may be due to /bin/hostname being moved from the net-tools package into the hostname package.
Comment 1 Bill Nottingham 2012-08-24 13:59:01 EDT
Added in git, will go out eventually.

Note You need to log in before you can comment on or make changes to this bug.