Bug 851736 - [ORIGIN] action_hook for python app needs to be updated for python2.7
[ORIGIN] action_hook for python app needs to be updated for python2.7
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 19:13 EDT by Peter Ruan
Modified: 2015-05-14 18:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 13:17:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2012-08-24 19:13:33 EDT
Description of problem:
  Which the latest release of Fedora, python has been updated to 2.7.3.  The current action hook for python app is python2.6 (see below).  The deploy hook has python2.6 hard-coded in there

command="ls ${OPENSHIFT_GEAR_DIR}virtenv/lib/python2.6/site-packages/Django*" 









remote: Processing Django-1.4.1-py2.7.egg
remote: Django 1.4.1 is already the active version in easy-install.pth
remote: Installing django-admin.py script to /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin
remote: 
remote: Using /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/python-2.6/virtenv/lib/python2.7/site-packages/Django-1.4.1-py2.7.egg
remote: Finished processing dependencies for YourAppName==1.0
remote: Making script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/pip relative
remote: Making script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/django-admin.py relative
remote: Script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/activate.csh cannot be made relative (it's not a normal script that starts with #!/var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/python)
remote: Script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/activate.fish cannot be made relative (it's not a normal script that starts with #!/var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/python)
remote: Making script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/easy_install relative
remote: Making script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/easy_install-2.7 relative
remote: Making script /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/bin/pip-2.7 relative
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: ls /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/lib/python2.6/site-packages/Django*
remote: ls: cannot access /var/lib/stickshift/f9c4050c88fe41dbacb1380133575d79/iqu5y25g1b/virtenv/lib/python2.6/site-packages/Django*: No such file or directory
remote: RESULT=1
remote: Starting application...
remote: Done
remote: Running .openshift/action_hooks/post_deploy
To ssh://f9c4050c88fe41dbacb1380133575d79@iqu5y25g1b-7vwb7t9bdi.example.com/~/git/iqu5y25g1b.git/
   30d1494..4b60100  master -> master


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mrunal Patel 2013-02-14 13:17:12 EST
Closing this since we have a python-2.7 community cartridge now.

Note You need to log in before you can comment on or make changes to this bug.