Bug 851742 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'create' accesses on the shared memory .
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'create' accesses...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:356f5d3bcd4acf2a1d126550b3e...
:
: 851761 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 23:36 EDT by Rafael Louback Ferraz
Modified: 2012-09-21 19:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 19:59:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Louback Ferraz 2012-08-24 23:36:01 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.2-3.fc17.x86_64
time:           Sáb 25 Ago 2012 00:35:38 BRT

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'create' accesses on the shared memory .
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If você acredita que o totem-video-thumbnailer deva ser permitido acesso de create em  shm  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep matroskademux0: /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Objects                 [ shm ]
:Source                        matroskademux0:
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           totem-3.4.3-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-145.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.2-3.fc17.x86_64 #1 SMP Tue Aug
:                              21 19:06:52 UTC 2012 x86_64 x86_64
:Alert Count                   38
:First Seen                    2012-08-25 00:34:46 BRT
:Last Seen                     2012-08-25 00:34:54 BRT
:Local ID                      b4871dba-8ac8-4675-b72f-24fe4727bcbf
:
:Raw Audit Messages
:type=AVC msg=audit(1345865694.808:199): avc:  denied  { create } for  pid=9252 comm="matroskademux0:" key=-559038737  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=shm
:
:
:type=SYSCALL msg=audit(1345865694.808:199): arch=x86_64 syscall=shmget success=no exit=EACCES a0=deadbeef a1=400 a2=7a4 a3=4 items=0 ppid=8773 pid=9252 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=matroskademux0: exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: matroskademux0:,thumb_t,thumb_t,shm,create
:
:audit2allow
:
:#============= thumb_t ==============
:allow thumb_t self:shm create;
:
:audit2allow -R
:
:#============= thumb_t ==============
:allow thumb_t self:shm create;
:
Comment 1 Miroslav Grepl 2012-08-27 05:47:57 EDT
It has been fixes in the latest policy build. You can install it for koji for now

http://koji.fedoraproject.org/koji/buildinfo?buildID=350108
Comment 2 Miroslav Grepl 2012-08-27 05:48:28 EDT
*** Bug 851761 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-09-17 08:13:14 EDT
selinux-policy-3.10.0-149.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-149.fc17
Comment 4 Fedora Update System 2012-09-18 22:54:49 EDT
Package selinux-policy-3.10.0-149.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-149.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14301/selinux-policy-3.10.0-149.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-21 19:59:00 EDT
selinux-policy-3.10.0-149.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.