Bug 851764 - calibre does not see ebook device [nook]
calibre does not see ebook device [nook]
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-25 09:14 EDT by rick
Modified: 2012-10-06 13:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-06 13:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug output from Kovid's device detect procedure from repo version 0.8.63 (6.20 KB, text/plain)
2012-08-25 09:14 EDT, rick
no flags Details

  None (edit)
Description rick 2012-08-25 09:14:57 EDT
Created attachment 606992 [details]
debug output from Kovid's device detect procedure from repo version 0.8.63

Description of problem:
calibre does not see device--nook simple w/light

Version-Release number of selected component (if applicable):
both current from repo=0.8.63 and from website=0.8.66

How reproducible:
every time

Steps to Reproduce:
1. start calibre - attach nook
2. attach nook - start calibre
3.
  
Actual results:
--device storage and SD chip not recognized
--calibre icons not created
--file systems not mounted

Expected results:
used to work on previous ver=F14
did clean install F17 on same hardware

Additional info:
--seems to be a permissions thing, see attached debug output
--fyi had to fix pulseaudio by adding user name to audio and dev groups again [no the authconfig thing didn't work]
--can mount both device and SD chip manually
--Kovid on Calibre forum agrees udev/udisk issue
Comment 1 rick 2012-08-25 09:25:39 EDT
--an oops on the fyi, should be audio and pulse groups
Comment 2 rick 2012-08-25 09:29:03 EDT
--and a clarification, the pulseaudio reference is wrt Bugzilla: #815413
Comment 3 Kevin Fenzi 2012-08-25 13:16:54 EDT
It sounds like you are logging in in a way that doesn't grant you normal console privs. 

How are you logging in?
Comment 4 rick 2012-08-25 16:17:07 EDT
I use e16 as a desktop so no GDM...it that the issue then?...for pulseaudio as well you think?

I have always just run e16 with 'startx' and have an '.Xclients-default' in my homedir...can GDM be setup to run e16 instead of the default clutter?...and would that solve the problem?
Comment 5 Kevin Fenzi 2012-08-25 16:22:56 EDT
Yes, this is bug 806491

Run 'startx -- vt01' 
(provided you are on vt01, use whatever vty you are on). 

Does everything work then?

Yes, gdm will offer anything with a .desktop file in /usr/share/xsessions/ as a available session type.
Comment 6 Kevin Fenzi 2012-10-06 13:28:52 EDT
I assume startx fixed this? Please re-open if not and we can try and track it down further.

Note You need to log in before you can comment on or make changes to this bug.