Bug 851778 - Could not create app from command line after trying to create app in web ui
Could not create app from command line after trying to create app in web ui
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Windows
unspecified Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-25 13:09 EDT by olegych
Modified: 2015-05-14 22:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 12:32:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description olegych 2012-08-25 13:09:03 EDT
Description of problem:
Could not create app from command line after trying to create app in web ui

Version-Release number of selected component (if applicable):


How reproducible:
sometimes

Steps to Reproduce:
1. tried to created jenkins app in web ui, but cancelled
2. tried to create diy app in cli, but got an error

  
Actual results:
Problem reported from server. Response code was 406.
Re-run with -d for more information.

MESSAGES:
Failed to create application scastie due to: Scalable app cannot be of type jenkins-1.4 diy-0.1

Expected results:
application created


Additional info:
Comment 1 Xiaoli Tian 2012-08-29 01:18:44 EDT
(In reply to comment #0)

Hi, olegych

Which command are you using to create the jenkins app or diy app?

If you want to create an non-scaling app, please try if the following commands works for you:

rhc app create -a &yourappname -t jenkins-1.4 

or 

rhc app create -a &yourappname -t diy-0.1

We do not support  scaling jenkins or diy app currently.

Thanks
Comment 2 olegych 2012-08-29 07:51:58 EDT
Hi, thanks for the info.
Perhaps the issue is not related to the fact that i tried to create jenkins app.
It's just the wording of the message that is confusing.
Comment 3 Clayton Coleman 2012-08-29 12:32:56 EDT
The message is being returned by the server, and sounds accurate.  Can you please describe what you input and what the error was?
Comment 4 olegych 2012-08-29 13:09:37 EDT
The message is confusing becase it mentions unrelated type, and because it says 'type jenkins-1.4 diy-0.1' like it's one type.

Note You need to log in before you can comment on or make changes to this bug.