Bug 851790 - Glyphs with multiple unicode encodings inhibit subsetting
Glyphs with multiple unicode encodings inhibit subsetting
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
17
All All
unspecified Severity low
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-25 16:43 EDT by Deron Meranda
Modified: 2012-09-05 06:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 06:14:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Report on all the glyphs with multiple unicode encodings (8.93 KB, text/plain)
2012-08-25 16:43 EDT, Deron Meranda
no flags Details

  None (edit)
Description Deron Meranda 2012-08-25 16:43:13 EDT
Created attachment 607011 [details]
Report on all the glyphs with multiple unicode encodings

Description of problem:
There are several glyphs which are mapped to more than one Unicode encoding at the same time. These glyphs inhibit automated subsetting because it is not easy to delete just one encoding slot without deleting both (as they share the same glyph object).  See the attachment for a listing of these glyphs.

Version-Release number of selected component (if applicable):
liberation-fonts-2.00.0

Expected results:
Ideally these cases should use a glyph reference where stroke information must be shared.

Additional info:
These glyphs are identified by looking at the alternate unicode encodings property of the glyphs. If using the Python scripting to FontForge, look at the 'altuni' member of the glyph.  Also each glyph object for each encoding slot should be a separate object.  For example in the regular serif font:

>>> font = fontforge.open('LiberationSerif-Regular.sfd')
>>> font[0xfb01]
<fontforge.glyph object at 0x7fdf4387d688>
>>> font[0xf001]
<fontforge.glyph object at 0x7fdf4387d688>

Notice how the glyph object id is identical for both U+FB01 and U+F001.
Comment 1 Pravin Satpute 2012-08-27 08:12:24 EDT
Yes, even fontforge says "It is possible to have one glyph assigned to two unicode code points (This is not recommended, but it is possible)."  

http://fontforge.org/charinfo.html

Glyph reference looks better option to keep consistency in shape of the both characters.

Thanks for identifying characters affected by this, i will do these required changes.
Comment 2 Pravin Satpute 2012-09-05 06:14:38 EDT
i have committed changes in upstream. will be available with next release. 
please reopen if any problem.

Thanks !!

Note You need to log in before you can comment on or make changes to this bug.