Bug 851791 - Clean up fonts, remove unneeded private use area glyphs
Clean up fonts, remove unneeded private use area glyphs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
17
All All
unspecified Severity low
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-25 17:05 EDT by Deron Meranda
Modified: 2012-09-05 09:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 09:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
List of private use area glyphs (3.20 KB, text/plain)
2012-08-25 17:05 EDT, Deron Meranda
no flags Details

  None (edit)
Description Deron Meranda 2012-08-25 17:05:09 EDT
Created attachment 607013 [details]
List of private use area glyphs

Description of problem:
Many of the fonts have several glyphs defined for the Unicode Private Use area. If these glyphs have no purpose they should be removed so that the Private Use area is empty.  This will help eliminate unintended conflicts with other fonts that may define private-area glyphs.

Version-Release number of selected component (if applicable):
liberation-fonts-2.00.0

Expected results:
The BMP private use area (U+E000 .. U+F8FF) should contain no glyphs.

Additional info:
See the attacment for a report on the list of existing private-use glyphs.
Comment 1 Pravin Satpute 2012-09-05 09:20:55 EDT
Thanks for pointing this, i also found #854601 during working on this.

In couple of places character U+F004 is referenced in other characters, so  kept it as it is.

Resolved and committed to upstream, please reopen if found any further problem in this.

Note You need to log in before you can comment on or make changes to this bug.