Bug 851835 - [rhvem][admin-portal] Unable to rename storage domain name in case of migrate master flow (or reconstruct)
[rhvem][admin-portal] Unable to rename storage domain name in case of migrate...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 All
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Maor
vvyazmin@redhat.com
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 05:10 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 11:43 EST (History)
9 users (show)

See Also:
Fixed In Version: SI17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs vdsm, rhevm, screen-shots (1.20 MB, application/x-gzip)
2012-08-26 05:10 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-08-26 05:10:12 EDT
Created attachment 607050 [details]
## Logs vdsm, rhevm, screen-shots

Description of problem:
Unable to rename storage domain name

Version-Release number of selected component (if applicable):
Verified on RHEVM 3.1 - SI15

RHEVM: rhevm-3.1.0-13.el6ev.noarch
VDSM: vdsm-4.9.6-29.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.298.el6_3.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64


How reproducible:
100 %

Steps to Reproduce:
1. Edit storage domain
2. Rename storage domain name
  
Actual results:
Failed rename storage domain
Get an error: “Cannot edit Storage. Only Storage Domain name is updateable.

Expected results:
Succeed rename storage domain

Additional info:
Reproducible with iSCSI and NFS storage domain.

Rhevm  log:
2012-08-26 11:33:13,714 WARN  [org.ovirt.engine.core.bll.storage.UpdateStorageDomainCommand] (ajp-/127.0.0.1:8009-10) [368d3694] CanDoAction of action UpdateStorageDomain failed. Reasons:VAR__ACTION__UPDATE,VAR__TYPE__STORAGE__DOMAIN,ERROR_CANNOT_CHANGE_STORAGE_DOMAIN_FIELDS
Comment 3 Allon Mureinik 2012-08-29 09:49:26 EDT
The flow to reproduce the bug is incomplete - in some scenarios this edit can work, see below.


Steps to reproduce:
1. Create a DC with two active SDs.
2. set the master to maintenance - both SDs will go down
3. Activate the SD that was not the master - it will force a reconstructions of the master metadata on this domain.
4. Try to edit the name of the SD from (3) - the error will appear.

In UpdateStorageDomainCommand, line 39, there is a check that only the name is changed.
This fails since the UI creates a new storage_domains object without the lastTimeUsedAsMaster property (defaults to 0), and the database version has it.
Comment 4 Maor 2012-08-30 04:57:52 EDT
Merged upstream at commit #2abf376438ef81aeb4362a41ad4a512f7c29b32e
Comment 5 Allon Mureinik 2012-08-30 07:34:18 EDT
Change-Id for that commit, for easier tracking:
I77de69fb8bd28a3c2c1ec1a9be576cb7b4e9dd69
Comment 6 Allon Mureinik 2012-08-30 08:44:07 EDT
change merged.
Comment 7 Haim 2012-09-05 08:40:40 EDT
verified on SI17. managed to rename storage domain and extend lun.

Note You need to log in before you can comment on or make changes to this bug.