Bug 851851 - calligra is FTBFS on ARM, qreal = float
calligra is FTBFS on ARM, qreal = float
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: calligra (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-08-26 09:10 EDT by Peter Robinson
Modified: 2012-09-24 17:16 EDT (History)
3 users (show)

See Also:
Fixed In Version: calligra-2.5.0-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 17:16:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-08-26 09:10:49 EDT
calligra > 2.4.1 is FTBFS on ARM.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1090429

Excerpt below. We've seen this before with other QT packages. 

cd /builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/filters/sheets/excel/export && /usr/bin/c++   -DMAKE_EXCELEXPORT_LIB -D_BSD_SOURCE -DSHOULD_BUILD_RDF -DCAN_USE_MARBLE -DDISABLE_NEPOMUK_LEGACY -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS -DKDE4_CMAKE_TOPLEVEL_DIR_LENGTH=21 -DCAN_USE_QTWEBKIT -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv7-a -mfpu=vfpv3-d16  -mfloat-abi=hard  -Wnon-virtual-dtor -Wno-long-long -ansi -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -fno-exceptions -DQT_NO_EXCEPTIONS -fno-check-new -fno-common -Woverloaded-virtual -fno-threadsafe-statics -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -fexceptions -UQT_NO_EXCEPTIONS -fexceptions -UQT_NO_EXCEPTIONS -O2 -DNDEBUG -DQT_NO_DEBUG -fPIC -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/filters/sheets/excel/export -I/builddir/build/BUILD/calligra-2.5.0/filters/sheets/excel/export -I/builddir/build/BUILD/calligra-2.5.0 -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi -I/builddir/build/BUILD/calligra-2.5.0/interfaces -I/builddir/build/BUILD/calligra-2.5.0/libs/kotext -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/libs/kotext -I/builddir/build/BUILD/calligra-2.5.0/libs/kotext/changetracker -I/builddir/build/BUILD/calligra-2.5.0/libs/kotext/styles -I/builddir/build/BUILD/calligra-2.5.0/libs/kotext/opendocument -I/builddir/build/BUILD/calligra-2.5.0/libs/flake -I/builddir/build/BUILD/calligra-2.5.0/libs/odf -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/libs/odf -I/builddir/build/BUILD/calligra-2.5.0/libs/koplugin -I/builddir/build/BUILD/calligra-2.5.0/libs/pigment -I/builddir/build/BUILD/calligra-2.5.0/libs/pigment/compositeops -I/builddir/build/BUILD/calligra-2.5.0/libs/pigment/resources -I/builddir/build/BUILD/calligra-2.5.0/libs/kundo2 -I/builddir/build/BUILD/calligra-2.5.0/libs/flake/commands -I/builddir/build/BUILD/calligra-2.5.0/libs/flake/tools -I/builddir/build/BUILD/calligra-2.5.0/libs/flake/svg -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/libs/flake -I/builddir/build/BUILD/calligra-2.5.0/libs/main -I/builddir/build/BUILD/calligra-2.5.0/filters/sheets/excel/export/../sidewinder -I/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/filters -I/builddir/build/BUILD/calligra-2.5.0/libs/textlayout -I/builddir/build/BUILD/calligra-2.5.0/libs/widgets -I/builddir/build/BUILD/calligra-2.5.0/libs/main/rdf -I/builddir/build/BUILD/calligra-2.5.0/libs/main/config -I/builddir/build/BUILD/calligra-2.5.0/filters/sheets/xlsx -I/builddir/build/BUILD/calligra-2.5.0/filters/libmso -I/builddir/build/BUILD/calligra-2.5.0/filters/libmsooxml -I/builddir/build/BUILD/calligra-2.5.0/sheets -I/usr/include/kde4 -I/usr/include/kde4/KDE -I/usr/include/KDE -I/usr/include/phonon -I/usr/include/QtXmlPatterns -I/usr/include/QtXml -I/usr/include/QtWebKit -I/usr/include/QtUiTools -I/usr/include/QtTest -I/usr/include/QtSvg -I/usr/include/QtSql -I/usr/include/QtScriptTools -I/usr/include/QtScript -I/usr/include/QtOpenGL -I/usr/include/QtNetwork -I/usr/include/QtMultimedia -I/usr/include/QtHelp -I/usr/include/QtDesigner -I/usr/include/QtDeclarative -I/usr/include/QtDBus -I/usr/include/Qt3Support -I/usr/include/QtGui -I/usr/include/QtCore -I/usr/include/Qt -I/usr/lib/qt4/mkspecs/default    -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -o CMakeFiles/excelexport.dir/__/sidewinder/utils.o -c /builddir/build/BUILD/calligra-2.5.0/filters/sheets/excel/sidewinder/utils.cpp
/builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.cc: In member function 'void KisToolPaint::stepAlpha(float)':
/builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.cc:472:35: error: no matching function for call to 'qBound(double, qreal&, double)'
/builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.cc:472:35: note: candidate is:
In file included from /usr/include/QtCore/qnamespace.h:45:0,
                 from /usr/include/QtCore/qpoint.h:45,
                 from /usr/include/QtGui/qcursor.h:45,
                 from /usr/include/QtGui/QCursor:1,
                 from /builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.h:22,
                 from /builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.cc:19:
/usr/include/QtCore/qglobal.h:1198:34: note: template<class T> const T& qBound(const T&, const T&, const T&)
/usr/include/QtCore/qglobal.h:1198:34: note:   template argument deduction/substitution failed:
/builddir/build/BUILD/calligra-2.5.0/krita/ui/tool/kis_tool_paint.cc:472:35: note:   deduced conflicting types for parameter 'const T' ('double' and 'qreal {aka float}')
make[2]: *** [krita/ui/CMakeFiles/kritaui.dir/tool/kis_tool_paint.o] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi'
/usr/bin/cmake -E cmake_progress_report /builddir/build/BUILD/calligra-2.5.0/armv7hl-redhat-linux-gnueabi/CMakeFiles 
make[1]: *** [krita/ui/CMakeFiles/kritaui.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Comment 1 Rex Dieter 2012-08-26 14:20:14 EDT
Yeah, looks like the usual qreal != float problem.  i'll try to take a look.
Comment 2 Rex Dieter 2012-08-26 15:14:56 EDT
%changelog
* Sun Aug 26 2012 Rex Dieter <rdieter@fedoraproject.org> 2.5.0-3
- calligra is FTBFS on ARM, qreal = float (bug #851851)

calligra-2.5.0-3 should take care of this, please confirm it does, and i'll push it upstream.
Comment 3 Peter Robinson 2012-09-24 06:39:36 EDT
calligra-2.5.1-1.fc18 builds fine so it looks good thanks Rex
Comment 4 Rex Dieter 2012-09-24 17:16:44 EDT
thanks.

Note You need to log in before you can comment on or make changes to this bug.