Bug 851854 - X fails to start on KVM vhost
X fails to start on KVM vhost
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-cirrus (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 10:00 EDT by John Ellson
Modified: 2012-10-30 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 19:48:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (9.69 KB, text/x-log)
2012-08-26 10:00 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2012-08-26 10:00:22 EDT
Created attachment 607069 [details]
Xorg log file

Description of problem:
X fails to start on KVM vhost when using the cirrus driver.

/var/log/Xorg.0.log (attached) ends with:

[    20.302] (==) Depth 24 pixmap format is 32 bpp
[    20.302] (EE) FBDEV(0): mmap fbmem: Invalid argument
[    20.302] (EE) FBDEV(0): mapping of video memory failed

Version-Release number of selected component (if applicable):
xorg-x11-drv-cirrus-1.5.1-3.fc18.x86_64
kernel-3.6.0-0.rc1.git6.1.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. reboot
2.
3.
  
Actual results:
No X

Expected results:
X

Additional info:
Comment 1 Cole Robinson 2012-10-30 19:48:56 EDT
On latest F18 with an F18 guest I can boot w/ cirrus fine, though there are some graphical issues:

https://bugzilla.redhat.com/show_bug.cgi?id=837282

Since there's been plenty of F18 changes in 2 months, closing as WORKSFORME. John, if you can still reproduce with latest bits, please the qemu command line (/var/log/libvirt/qemu/$vmname.log if you're using libvirt/virt-manager). And if you are using cirrus with an existing guest, or trying to install a new one.

Note You need to log in before you can comment on or make changes to this bug.