Bug 85187 - gnome2 library chain has no static libraries
Summary: gnome2 library chain has no static libraries
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glib2   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-26 13:50 UTC by Frank Belew (frb)
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-26 14:42:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Belew (frb) 2003-02-26 13:50:55 UTC
Description of problem:
There are no static libraries for any of the packages in the gnome2 library set.
This includes glib2

I'd be happy even if they were in a separate package  such as glib2-static

Comment 1 Owen Taylor 2003-02-26 14:42:52 UTC
$ rpm -qpl glib2-devel-2.2.1-1.i386.rpm | grep '\.a'
/usr/lib/libglib-2.0.a
/usr/lib/libgmodule-2.0.a
/usr/lib/libgobject-2.0.a
/usr/lib/libgthread-2.0.a

They are there for glib2. (As of relatively recently.) Above that,
it gets to be a huge PITA to do static libraries because of the
heavy use of dynamically loaded modules. Plus, Pango and GTK+
require various config files on the system for correct operation,
so it doesn't real give you the "distribute binary without library"
thing that people usually want static libs for.


Note You need to log in before you can comment on or make changes to this bug.